Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Issue: Applications Not Appearing as Available for End Users

Seem to have an issue with applications loading up within the APPs section of Power BI Service.
I have many users from the companies we work as consultants reporting the problem.
Please, can you see what is causing the problem.

There is another post in the community on the topic:

Applications Not Appearing as Available for End Us... - Microsoft Power BI Community




Status: Accepted
Not applicable

We are experiencing the same issue.  This started today, 9/28/2021.  

Resolver I

@AntonioPalomas @Anonymous I was experiencing something similar but it appeared to be isolated to Google Chrome. I was able to see all my Apps via the Microsoft Edge Browser. I cleared my cache on Google Chrome and then logged back in.  The issue was resolved.  Please try to clear your cache. 


Regular Visitor

@hvnter Thank you - I have also experienced this with Chrome and clearing cashe worked. 


Power BI Team - will this be addressed where we do not need our Chrome users to clear cashe? This is causing user difficulty. 


Thank you. 

Community Support


Unfortunately, I can’t reproduce the same issue as yours.

I can successfully open the APPs page and view the APP list in my side.



I think you can try to sign out and sign in to the Power BI service using the inPrivate window of your browser to check if the problem can disappear.


Best Regards,

Community Support Team _Robert Qin

Helper I

We're also getting the same issues with our tenant.  Started sometime between 0900h and 1000h BST.


EDIT: We've checked, and the issue seems to be affecting Edge, but IE and Chrome are fine.  However thats not really a suitable workaround as our users are being moved to use Edge for our corporate applications.

Helper I

Further to my previous post, we also tried an InPrivate window, and the Apps page worked fine.  As such, we had users clear the cache in Edge, specifically the following;


Cookiees and other site data

Cached images and files


...and its working fine now.


However something in the service has clearly changed, something Edge specific, that means the currently cached files/cookies/etc aren't compatible with the change, and must be cleared, and downloaded again.

Not applicable

We are facing similar problem fro mtoday morning. 
Apps junt do not appear, stuck on bulding your app.


Cache, incognito mode, orher browsers tested - no success. 

Helper II

I am having a similar issue. My list of APPS is loading, but when I click on one, I am taken to the app's reports/pages and see a "Building you app..." message that never ends, and the content does not load. I have cleared my cache from Google Chrome, tried accessing it on Microsoft Edge, tried incognito mode on Chrome, and have signed out/signed back in. Any other thoughts on why the app's contents wouldn't load? This issue started yesterday, 9/28/21. Any updates from Power BI on this issue would be great appreciated. Thank you. 

Frequent Visitor

A subset of users, including myself, are also experiencing this issue.  Microsoft Edge and Google Chrome.  Have tried clearing cache, clearing cookies, logging out/in, etc.  Still stuck on "Building Your App" when clicking on certain Power BI Apps (not all).  Accessing reports from Workspaces generally work.  Here are some screenshots from the dev screen in Chrome:


Some sort of subscribe request is failing/getting canceled:


The difference in logging between an app that is sticking on "Building Your App..." and one that doesn't is that StringValueTooLong error message shown above.  This issue started on 9/28/21.

Regular Visitor

SAme issue, once the cache is cleared in chrome and logged back in they appear, until i leave the app page then they do not re-appear.