Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Stuck at Creating Connection Model

I am stuck at this point when I click on the Refresh button. Looks like there is a problem in September 2021 update, I've downgraded to August and it's working fine.



Status: Accepted
Regular Visitor

Yes, the same issue with me as well

Regular Visitor



Please have this issue fixed at the earliest.

Regular Visitor

Faceing similar kind of issueI was having the same problem, update sticks on Connecting to Data

how to downgrade Power BI back to August??

Community Support


I’ve got this message from pg:


Found the root cause, discussing a fix


Best Regards,

Community Support Team _Robert Qin

Frequent Visitor

Hi All,

I'm having the same issue.

I ran the same report* on two different computers with the same specs (same CPUs, same RAM, same network with virtualization), the only variable being the September release:


*I used the technique I described for sequential loading under the following post


I timed the load side-by-side;

Both versions were started at the same time.

Both said they loaded the sample data in ~180 seconds... however the September version took an additional ~180 seconds to connect even to the SYSDATE in the oracle SQL server.





Also, the September version does not display the row count progress.Screenshot 2021-10-07 195034.png

I tested it multiple times and reproduced the issue. Load times have doubled for the same report.

Thankfully connecting to SYSTIME only takes a fraction of a second. The sample data takes 3 minutes consistently in the previous Power BI release and 6 minutes in the September release.

Regular Visitor

Any update soon is appreciated. The past few weeks have been very hard for data refreshes. One of our complicated models that used to take 30 minutes, now takes about 2 hours. 

New Member
I had the same issue after the September 21 update but our IT resolved by increasing the RAM more than 16GB as the new update require more RAM. However, it still does not show all the steps during the refresh but it eventually finish and update the data.
Not applicable

Exact same problem, this solution worked (roll back to August) 



Frequent Visitor

I have the same problem and actually I have been having it since the August update on one particular machine.  it doesn't matter what dataset i use, local or published nor does it matter the type whether it's Excel, CSV or SQL. I can't even create a new report.  I've uninstalled and reinstalled with no success.  Please HELP!