Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

0

Power BI scheduled refresh stopped refreshing without errors

Hi there! 

 

I got an unwelcome surprise this morning when my scheduled refresh suddenly stopped working. I made no change to the report file and no changes to the refresh schedule and PowerBI service shows no errors whatsoever.

 

The refresh schedule speaks volumes:

jaap_olsthoorn_0-1666682387164.png

It says my "next refresh" is in the past (you can see its the past because of the successful refreshes under it). I have never experienced this in my Power BI career, and without any error messages it is completely invisible. What could be going wrong here?

 

Thanks!

Jaap

 

Status: Delivered

Hi @jaap_olsthoorn 

This is a very strange phenomenon indeed. In any case, it's normal now. No need to delete the previous dataset to use it properly, thankfully .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
jaap_olsthoorn
Advocate II

Oh man, so it's not even isolated. We just have to wait till someone at Coca Cola or Goldman Sachs gets the issue so they take it seriously and really get the engineers involved.

 

Good luck! Hope it fixes itself like it did for me! 

Anonymous
Not applicable

And a week later, it started back up on its own, just like yours did 😂 

jaap_olsthoorn
Advocate II

Haha awesome 😄 I'm glad!

Cam_Cod
Regular Visitor

@jaap_olsthoorn ,  Thankfully I found your thread here.  I am currently in the exact same position with the same type of environment that you described on 10/25 and which @Anonymous also expereinced on 11/5 .  My situation began 11/26 out of the blue.  Tonight, I nearly pulled the "delete' dataset trigger after my same futile steps to remediate.  12/1 is my 1 week hold out date.  You guys have potentially saved me hours of work.  I'll be manual refreshing fool until then.

Thanks,
Cam

jaap_olsthoorn
Advocate II

Really hope it works out for you as it did for us. Good luck!

jaap_olsthoorn
Advocate II

And @Cam_Cod, did it come back to life?

Cam_Cod
Regular Visitor

@jaap_olsthoorn , yes it did.  One week on the dot. 

However, today (1/18) the issue started again out of the blue. 

 

Came back to this thread to see if anyone else reported an issue since.

Anonymous
Not applicable

@v-yetao1-msft @Cam_Cod and @jaap_olsthoorn 

This issue has started for me to today. It is in a dataflow and we have maybe just under 10 reports / datasets running from this. Any further ideas? The source is Project Online (Microsoft / MFA )

 

Thanks

Anonymous
Not applicable

This morning the issue has resolved itself, but it is quite a concerning one. With the frequency / occurance it is happening from this thread, it is making the service potentially unreliable. If it can just stop with no warning and as described above, would take a lot of time to fix / resolve. Any ideas what is causing this?


jaap_olsthoorn
Advocate II

No idea, it hasn't happened for me since, but I did all the work in moving to a different dataset. The problem is that when you contact support, they will want you to show them which refreshes are going wrong, and you can't give them a refreshID because there is none. So they will say they can't help you without a refresh ID.

 

If anyone knows how to contact an engineer directly, that would be great, but my experience through support so far is that they can't help you.