Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Dataflow Refresh - Internal Error


Since last friday i'm with some issues in refresh my datasets. Most of the the refreshes that we try returns an internal error:



Error: Internal error Request ID: ad8067f3-103b-4cde-a815-9869e2a3f98c Activity ID: 00000000-0000-0000-0000-000000000000




My dataflows are connected to Google BigQuery, with Powerbi Connector,  and this never happened in the past. 
the error always happens at different refresh times, different entities,  and happens on all the Dataflows we have on the server on the various PRO accounts.
Do you have any idea of what is happening for this error


Status: New
Helper II

New day, New error

Error: The parameter is incorrect.


Regular Visitor

I was getting the same internal error all week. Yeterday the dataflows finally started to complete and I thought we were out of the woods.

Today All dataflows are failing:

Error: Can't convert 9 to proper M credential Type Request ID: 21d00223-d272-afd5-6c07-186d3e42ed8a Activity ID: 2d637019-69c5-435c-9b3a-f8cc809f90b6

Regular Visitor

I was getting the error in the Original post intermittently as well - primarily for one datasource. Today, I wake up to all datasources that require the use of a gateway throwing this error message

Error: User is not authorized to access the gateway. Request ID: b3addc42-88af-5aff-d5b0-50fb94e8a4d0 Activity ID: 5771cdcc-f79c-4077-9470-3f27e6cd5789

EDIT: I should specify, I did test this on a Dataset refresh using the exact same gateway and received no error. I reached out to our PBI Service admins and they verified we are still authorized users of the gateway. I tried creating a brand new dataflow to see if it was only impacting existing dataflows whereas perhaps newly configured dataflows might avoid the same error... but I got the same error message (Error: User is not authorized to access the gateway. Request ID: 6c0fc5d7-37ca-6204-b0fd-53374dc802ae Activity ID: 875f9d38-45e9-42a6-8b22-8bf9c9175c58) so I can confirm it is not localized to pre-existing dataflows.

Data source connection types in which we use gateways (all are impacted):

  • MS SQL Server (2 different servers)
  • Vertica
Advocate II

Getting "User is not authorized to access the gateway" on all dataflows in my tenant (North Central US) that require a gateway. 

On the phone with MSFT support and they say there's lots of similar issues reported today. 

Kudo Kingpin

Since yesterday (14-May) there refreshes are running smoothly.
Was the issue fixed?

A statement from Microsoft would be nice.


Guys, we know that you do a lot, and understand that issues happen.

But, please, acknowledge and keep us informed so we can keep our customers/employers informed.

It is just professional.

Thank you 

Frequent Visitor

Same here. Looks like the issue is solved. Let's wait couple more days. Just in case.

Advocate II

Still not fixed in my tenant

Memorable Member

This issue should be sorted now:

I've not seen any further issues recently.

Kudo Kingpin

And again - failed with general error this morning (16-May 6:00 AM)

Advocate II

Still not fixed. Monday is going to be a disaster.