Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Bug: Datamart Loading Data Internal Error Code 500 - Failed Runtime Assertion

I was updating our datamart and was given the following Internal error message:

InternalError

  • ErrorMessage: An internal error happened due to failed runtime assertion: Unable to change Model locale after other objects have been created..
  • HttpStatusCode: 500

 

This also occurs when I haven't updated anything in the datamart and follow path Transform Data -> Save -> Error Message

Status: Needs Info

Hi @OHMark 

Do you have this problem with all your dataflow?

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
v-yetao1-msft
Community Support
Status changed to: Needs Info

Hi @OHMark 

Do you have this problem with all your dataflow?

 

Best Regards,
Community Support Team _ Ailsa Tao

OHMark
Regular Visitor

Hi @v-yetao1-msft,

 

No, just on one specific Datamart.

 

This occurs when saving the Data Trasnform in the Datamart so that the Datamart pushes changes/measures/new data into the Default Dataset (No matter if I am making changes or not). I get the error here:

OHMark_0-1689929895941.png

Let me know if you need more information.

luizraposo
Regular Visitor

Hi, I'm facing the same problem: "An internal error happened due to failed runtime assertion: Unable to change Model locale after other objects have been created..". I didn't do any updates before the errors started

cedar
Frequent Visitor

Hi, got the same issue with the datamart

 

cedar_0-1690265735549.png

 

Dianis08
Regular Visitor

Hi,

 

I am having same issue with my datamart. I haven't been able to update it.

 

Capture.PNG

 

I would appreciate any help. Thanks.

luizraposo
Regular Visitor

It looks like the default locale is buggy. I switched to USA and it solved my problem

v-yetao1-msft
Community Support

Hi @OHMark 

You can try the method provided by @luizraposo and check whether your datamart can load data ?

 

Best Regards,
Community Support Team _ Ailsa Tao

MJMB_35
New Member

Hi, i have the same problem and i didn`t do anything.

@luizraposo where do you mean we need to switch the default local?, more detail please.

Best regards.

ekspo
Regular Visitor

Hi, same issue in my datamart, any update?

ivandavidbt
Frequent Visitor

Hello team!

Same problem here loading information from Dataflow, any update?

Thanks!