Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Subscriptions not sending

Automated subscriptions did not send from either workspace after refresh. REfresh succeeded but no email. Went to the dashboards and manually ran subscriptions. Still no email received. Normally emails are received at 7:00 am EST.

Status: New
Helper IV

Mine are coming in as well but are experiencing the same 1 hour delay.

Advocate II

I have a mix; some have arrived on time, some an hour late, some 3 hours late, and some have not yet arrived.

New Member

Very same issue. We have a number of subscriptions. In the last few days, some emails are being generated/sent, but the majority are not.


Can't seem to open a ticket with PBI - clicking the button does nothing.


Very frustrating to not have MS or the PBI team be taking this seriously and updating on a resolution. The status page indicates "no issues" which just makes this more frustrating given that this thread started on April 16th.

Advocate III

couldn't agree more @danbelhassen I have also tried to log a ticket with Microsoft and the link does nothing.  very frustrated that the support page claims no issues.



Advocate I

Looks like the issue hasnt cleared itself yet.  Its been over an hour and my 6:30am EST refresh notifications havent shown up yet.

New Member

Hours after I requested them (again), I started receiving them. However, the previous ones from Monday seem to have completely vanished.


Microsoft - we (obviously) need the emails to be generated consistently and predictably.. but if you have a problem - let us know you're working on it, at least!

Helper I

I logged a support ticket and I suggest everyone else does as well.  They fixed the button so you can now log one.  


This has been essentially an on/off issue for 2 weeks now with very little communication from Microsoft.

Advocate I

I'm having this issue again -- its been 20 minutes or so since my refresh and no eamils have come through.