Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Slicer dropdown not showing data

Occasionally when I click the drop down arrow on my slicer, a small white box will appear where the drop down is supposed to be, but with no data displayed. I can fix the broken slicer by refreshing my browser page. This particular report has several slicers, and the issue can randomly occur on any of them with drop downs. This issue appears to only occur in Power BI Service, not Power BI Desktop. 



Status: New
Community Support



I tried the latest version to publish a report and it seems to work fine for me. 

Advocate II

I'm having pretty much the same issue. It appears only on the Power BI service and seemingly effects only drop-down slicers with relatively few items. Once you click the dropdown the second time it works normally (at least for me).


Linking to my same issue here for visability -

Not applicable

@v-chuncz-msftI republished the report with the updated version of PowerBI Desktop. The same issue persisted. Note that upon initial load of my report the slicers will work fine. It is only after I have changed pages (usually it takes 1-5 page changes of my report) before I see the issue occur. 


@abayless I have to refresh the broswer page in order to fix my slicer. Clicking it a second time doesn't help unfortunately.


The temporary work around I found was to simply not use dropdown slicers.

Community Support



I cannot reproduce the same issue. But you may keep an eye on the post below.

Super User

Hi all,

If you are still finding the issue persists, it may have something to do with Power BI Online's view of the Dashboard.  I recommend viewing in full screen mode when you're in Power BI Online.

The above should work if the PBIX version (Power BI Desktop) is showing the drop down slicer with a number of different options.


Frequent Visitor

Hi All, 


Noticed this issue is still happening for some users in the Power BI Service. We found that if you view the report in 'Actual Size' the issue should disappear.



New Member

Hi team


Have just tried across one of my reports. This only happens when using fit to page. When trying to use fit to width, full screen or actual size, the drop down slicer works fine.


When using fit to page, if I increase the screen real estate, I can see the drop down does appear. Not below the slicer like normal, but off to the right, which would be off the screen normally. When testing in normal view, this behaviour does not create a scroll option in the browsing window either.


Thanks team for the suggestions.

Frequent Visitor

HSymes-Thompson - Thanks for the suggestion. This work around works. We are having the same issues for lots of users, for reports that previously worked fine.

Post Prodigy
Post Prodigy

Doesn't work for me. It only works in Actual size mode, but the report becomes oddly small. Fit to page works only if I minimize browser window and then expand it to the screen size by dragging side borders. The slicer drops down somewhere at the right edge of the screen though. Very strange as the report worked fine for months, has never been changed, just being refreshed in the gateway.

Super User

@gvg if you view in full screen mode, does it work?

I am going to go out on a limb here and say that there has been a reset change to the "frame" sizing / structure of the Power BI Service report view window... Otherwise, it could be something to do with the "resolution" of screens (i.e. going to make a guess and say that most people experiencing this are those running 4K or higher res monitors...).