Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

SharePoint data source - authentication method service principal not working

It seems that the authentication method 'service principal' does not work for the SharePoint datasource in Power BI service -> dataset -> settings - edit credentials. By reading some documentation it seems that the only way to get data from the SharePoint API is via client certificates, maybe why it does not work (anymore) for client secrets. I presume this uses the SharePoint resource 'https://microsoft.sharepoint.com' and not the Graph resource 'https://graph.microsoft.com/' under the hood.

Capture.PNG

 

Kind regards

Status: Investigating

Hi  @naelske_cronos 

I found a document related to connecting to SharePoint using service principal that you can refer to. Hope this will help you.

How to connect SharePoint online using service principal? - Microsoft Q&A

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
v-yetao1-msft
Community Support
Status changed to: Investigating

Hi  @naelske_cronos 

I found a document related to connecting to SharePoint using service principal that you can refer to. Hope this will help you.

How to connect SharePoint online using service principal? - Microsoft Q&A

 

Best Regards,
Community Support Team _ Ailsa Tao

naelske_cronos
Helper III

Hello,

 

Thank you for the links but I don't see how this helps me with this example with setting the credentials in the Power BI service. The link you showed talks about how to do this with PowerShell and most of blogs are talking about certificates and not client secrets.

Picture1.png

Capture.PNG

 

Is there a possibility to test this out and tell me what I exactly need to get this working to get this working in Power BI service for SharePoint?

 

Thanks in advance

Kind regards

sheepworrier
Frequent Visitor

Any update on this one please?  I have the same issue

Mariza
New Member

Did you find a solution to this? I'm having the same issue

Marizach
Frequent Visitor

@naelske_cronos Did you happen to get this to work? I'm facing the same issue and wanted to know if those permissions you granted the service principal would be enough.