Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

SQL Connection - "0 - The certificate chain was issued by an authority that is not trusted."

Following update to "Version: 2.126.927.0 64-bit (February 2024)" I can now nolonger connect to a particular slq server.


Microsoft SQL: A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.)


This is not my server and it does not support encryption.  Until now I have been able to turn off encryption and have not had any SQL Certificate Chain errors.


I can still connect with the same settings via SSMS.  I don't think I can try things like trustcertificate in the connection string with PowerBI.


Has anyone a solution to this or any reports that this is a bug to be addressed would be much appreciated.







Status: Accepted

Hi all,


We have seen on the internal platform that other engineers have reported this issue and submitted it.
The engineers on the product team are now aware and will do their best to resolve the issue. I will update here if there is any progress, so please be patient.


Best regards.
Community Support Team_Caitlyn

Advocate I

Still a problem so far as I know. Env variable and config file ideas did nothing.  Had to backdate by powerbi desktop and gateway versions for now and hope next version sorts it.

Regular Visitor

Hi @craigchamberlai 


Thank you for sharing. Unfortunately, I'm in part of a set of users and I'm not admin of the server.

Did you say that to "fix" scheduled refreshes in PBI Service you had to downgrade the Data Gateway version?

Advocate I

Yes @elio-douglas unfortunatley the other suggestions didn't work for me but might be worth it for you.  I was thinking about trying to proxy the sql server, kind of make my own "man in the middle" so I could add a certificate and set up properly but went with rolling back the version for now.  I feel like it's likely to be addressed in future versions but who knows.  There is no excuse for rocking a SQL server without a cert.

Advocate II

hi @craigchamberlai 


have you used the March 2024 release and does it fix the issue?




Advocate I

@UOLandrewdale not tried waiting a few versions or confirmation from others.  Happy with old version for now.

Regular Visitor

@UOLandrewdale   Yes, just tried the new March version (Version: 2.127.1080.0 64-bit (March 2024))  and it doesnt appear to be fixed, and Im getting the same error.

Frequent Visitor

I also tried the March version and I'm still getting the same error.  I reverted back to the December release which allowed an unencrypted connection.



Regular Visitor

Have reveived an update to Version: 2.127.1327.0 64-bit (March 2024), and still getting same error


Is there any news, since it was 'Accepted' as an issue on 20th Feb?

Helper I

We rolled our version back to December 2023 to resolve the issue so we could run our reports. Not sure I will want to update versions in the future if this does not get resolved.

Regular Visitor

Now on second April update - 


Version: 2.128.952.0 64-bit (April 2024)


and its still the same, whether its refreshing existing data within a report or creating new report.  I'm unable to access any data because of this certificate issue.