Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Right-click on Matrix visuals unresponsive

Right-clicks on Matrix visuals in a published report are no longer displaying any options and have become unresponsive.  These were functioning as expected as recently as 25-Feb but as of 26-Feb are behaving in this manner.  A conversion of the matrix visuals to table visuals has restored the expected right-click functionality, so the issue appears to be isolated to just matrix visuals.  Have there been any global updates to matrix visuals in Power BI that would explain this behavior?  Thanks!

Status: New
Not applicable

Our group has noticed the same thing. No context menu pops up when we go to right click a matrix visual as of about 10 minutes ago.

Community Support

@jflipse ,


It's weird, I have made a test but the options pop up when right clicking the matrix on my side. This issue should be related to the tenant region. I would suggest you submit a support ticket here for further analysis.

Support Ticket.gif 



Jimmy Tao

Impactful Individual

@v-yuta-msft  I have had the same issue with our drillthrough (right click) on a matrix on 1 model of is completely unresponsive.  Please see the entry I've made to this forum here.  It's really a problem for us as we depend on drill-through as key functionality!



Frequent Visitor

We are also having the same issue on both Matrices and Table views.   It works fine in PowerBI Desktop, but not our published reports/applications.


Previous issues like this have been solved by using other browser, using the Refresh button, etc. but none of that seems to work.

Helper II

Same issue for me.

its working using the Power BI (store edition), working in Power BI Desktop (store edition)

but not on the web.


Advocate III

@v-yuta-msft ,


I had not noticed the issue until seveal of our users complained.  I then tried it in the Service and did not see the issue - until I closed and re-opend my browser session, then I was able to recreate it.  My previous browser session had retained the expected behavior since, I presume, it was refreshed/opened prior to the issue appearing.  Thus it worked as expected in the "old" session but once I refreshed it no longer worked.


So, I guess if one has an older browser session open and the right-click still works, don't close the session😛

New Member

My organization is having the same issue on multiple reports in the service. This functionality was working a couple of day ago and isn't working any more. If we switch the visual to a table it works, but the matrix visual isn't working. It is fairly key functionality, and we have a lot of users complaining so hopefully it gets resolved soon. 

Advocate III

I have asked my company's support team to raise a ticket directly with Microsoft support about this (I am unable to raise it directly myself apparently), so hopefully that will be on their radar soon, if it is not already.  🤞

Impactful Individual

@v-yuta-msft  I sure wish all of my users had an old session open!  I hope you can get us some service team help!


Thank you,


Regular Visitor

Same issue here. We have several high-profile matrix reports that users interact with consistently so this has a huge impact to us. Hopefully Microsoft can address and fix soon.