Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Power BI Source Control Does not Allow One to Check out the main Branch

I recently added source control to a Power BI workspace.


I was able create a new branch (which is called "Checkout new branch"), make changes to a report, and commit the changes.
I was able to see the changes in the branch in Azure DevOps, and merge them into the main branch. The merge removed the working branch during the merge. I am not able to check out the main branch.




Power BI / Fabric:

  1. does not seem to be aware of the merge
  2. does not give one the option to switch back to the main branch
  3. will only let me create a new branch

The most basic flow I can think of is new branch from main --> do work --> test --> merge branch to main --> relax with my thoughts. Is this possible with Source Control in Power BI? I can't imagine this is the expected behavior.


Status: Needs Info

Hi @lysdexia 

Can you describe your procedure in detail ?


Best Regards,
Community Support Team _ Ailsa Tao

Community Support
Status changed to: Needs Info

Hi @lysdexia 

Can you describe your procedure in detail ?


Best Regards,
Community Support Team _ Ailsa Tao

Regular Visitor

0. I have enabled source control on a Power BI Workspace using a project on

1. I use the "Source control" button in the Power BI Workspace to create a new working branch.

2. I add a report and / or a dataset to the branch (if it's not already being tracked)

3. I make a change to a report and / or dataset

4. I commit the changes and push to remote (the project on

5. I have a look at the changes on

6. I create a "Pull request" on

7. I merge the changes (which "squashes" commits and removes the working branch).

8. I return to the Power BI Workspace



9. I click "Source control" and see the following:

Unable to complete action

You can't complete this action because the branch was deleted. Connect to a different branch to continue.
Hide details
Cluster URI

Activity ID 254e3bc5-b294-428d-b234-3ab2e1cf6b4b

Request ID eda7486a-668f-894c-0822-813d24663dcd

Time Mon Jun 12 2023 08:54:26 GMT-0400 (Eastern Daylight Time)

10. The "Source control" side bar gives me only the option to "Checkout new branch". I can no longer select the "main" branch.


It seems obvious to me that my "Source control"-enabled Power BI workspace should:
1. Supply one with a default option to check out the "main" branch (which, of course, now has the changes one has approved and merged into "main")

2. Not treat one of the most basic options associated with a Pull Request (i.e. deleting a working branch from the remote server after merging with "main") as a breaking error.


Is this clear enough, or do you have specific questions on any point?



Regular Visitor

@v-yetao1-msft anything to report?

Regular Visitor

@v-yetao1-msft is the information I supplied on 2023-06-12 enough?



Regular Visitor

@v-yetao1-msft  is this on anyone's radar at this point?


Regular Visitor

@v-yetao1-msft Is the information I provided adequate?


Frequent Visitor



We are seeing a similar issue.


We are expecting this drop down to show all branches, not just the newly created branch, to easily allow developers and QA to switch between branches.


Is the only option to switch to another branch in the repository by using workspace settings?



Regular Visitor

I have a feeling that this will be solved in 59 days.

Regular Visitor

I have the same issue as @lysdexia who did a fantastic job of outlining the steps I took. with the same issues.

Even after going to the Workpace Settings and changing the branch back to Main and clicking switch and override. This fails and tells me that something went wrong
@v-yetao1-msft  any update on this error

Regular Visitor

Ok So I got it working.
I had to create another branch as one of my reports was Live connected. 
Removed that report and merged the change in devops and then before removing the branch. Workspace i changed the branch back to main and it worked.
@lysdexia  @v-yetao1-msft