Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Power BI Desktop - intermittent bug - measures disappearing

We have many "report .pbix" files that are reports with a live, "Power BI datasets" connection to a common dataset. In some of these reports, we have created what I'd call "additional measures." That is, these measures were created in the "report .pbix" only, and the measures don't exist in the dataset to which it has a live connection.


Since several days ago, approximately, many of our users (and I) have experienced the follwing issue...


Sometimes when we open the report .pbix in Power BI Desktop, some visuals are broken because the "additional measures" seem to be missing. The visual says: "Something's wrong with one or more fields" or "Something's wrong with one or more filters." And when we click "See details," the pop-up says: "Can't display this visual. This visual contains one or more filters with deleted columns, type mismatches, or other breaking model changes." Or the pop-up says: "Fields that need to be fixed / Something's wrong with one more more fields: MeasureA, MeasureB."


And when I look in the "home table" where the measures should reside, they are not there anymore! This only seems to happen with "additional measures" that are created in the "report .pbix," which is connected live to a published dataset. (We have not experienced this issue with measures that exist in the dataset.)


And it happens only intermittently -- sometimes, seemingly at random. For a given file, sometimes it happens when I open it in Power BI Desktop, sometimes it doesn't. When this issue occurs, I can close Power BI Desktop (without saving any changes); then re-open the exact same file, and everything is fine -- the visual has no errors, and the "additional measures" appear in the expected home tables.


As a test, I just closed and re-opened one such file 10 times, without doing anything else on my computer in between, and this issue occurred 5 out of the 10 times.


I am using Release: December 2020 / Product Version: 2.88.802.0 (20.12) (x64) ... this may only happen with the December release of Power BI Desktop. Haven't tested with older versions.

Status: New
Continued Contributor

Details of error

Feedback Type:
Frown (Error)


Local Time:

Session ID:

December 2020

Product Version:
2.88.802.0 (20.12) (x64)

Error Message:
This visual contains one or more filters with deleted columns, type mismatches, or other breaking modeling changes.

OS Version:
Microsoft Windows NT 10.0.19041.0 (x64 en-US)

CLR Version:
4.7 or later [Release Number = 528372]

Peak Virtual Memory:
38.3 GB

Private Memory:
621 MB

Peak Working Set:
756 MB

IE Version:

User ID:

Workbook Package Info:
1* - en-US, Query Groups: 0, fastCombine: Disabled, runBackgroundAnalysis: True.

Telemetry Enabled:

AS Live Connection:

Performance Trace Logs:
C:\Users\***************\AppData\Local\Microsoft\Power BI Desktop\

Enabled Preview Features:

Disabled Preview Features:

Disabled DirectQuery Options:


DPI Scale:

Supported Services:
Power BI


section Section1;

Not applicable

Yes, this issue has been a problem & seems to occur at random times

Community Support

hi @kevhav 

i have tested on my side, i create five pbix file as you said, reopen them several times, they all works well.

my power bi desktop version is: 2.88.1144.0 64-bit (December 2020)


please upgrade power bi desktop to the latest version and give it a try.




Advocate IV

Try clicking the "Refresh" button on the report.  Seems silly, but this has resolved for me when this recently happened to me.  I was concerned I lost my DAX and went searching through the unzipped version of the PBIX file to make sure I could recover it.  But turns out that was unnecessary (good to know as a back up though).  It seems to resolve if I click refresh - the report-only measures come back as if by magic!  This has happened to me intermittently, but I believe it is likely triggered when a new version of the dataset is published on PowerBI Service.  This might not solve for you, but is worth a try.  Best of luck!

Continued Contributor

@SMHolck clicking "Refresh" works to "bring the measures back." Thank you very much for the workaround!


@v-lili6-msft I upgraded to version 2.88.1144.0 64-bit (December 2020) but just today, I am still experiencing this issue (intermittently). I still believe this is a bug, though I don't know exactly what conditions are required to reproduce it. In my experience, it is not "triggered when a new version of the dataset is published on PowerBI Service." It can be triggered without a new version of the dataset being published.

Advocate I

I have this same exact issue. It never happened before the December release. I've seen it across multiple PBI files which never had issues before.


In addition, about every other time I also have to sign in and wait before it opening the PBI file. I've attempted to completely clear my user profile settings which didn't help.


These two issues combined has made getting into work on PBI files tedious. I hope they can get resolved in the January release.



Helper I

I have also been seeing this - it seems to be connected to authorisation. It used to be that when I started Powerr BI it would remember my last signed in credentials but some months ago this stopped and I am prompted to enter an email. However - it does not matter what email I enter (I can even just enter rubbish) it then signs me in with the previous sign in.


However - sometimes when I open a second report it prompts me for an email and sometimes it does not.


If it does NOT prompt me that is when I get this error - it is as though all the measures local to this report have disappeared. If I close all Power BI instances and then start again (making sure it prompts me for my credentials) then they come back!


I even had an occasion when I did not know I had the error (as it was on one of the pages I was not editing) and it was only when I went to that page after having made several changes that I realised it. When I saved and closed the report and then re-opened it (with the prompt for credentials) then the local measures re-appeared!


Not applicable

Hi. I'm facing the same issue.

Frequent Visitor

Had the same problem. Solved it by clicking "Refresh". Thank you so much for help @SMHolck & @kevhav !

Advocate I

Happens to me and my co-workers too. The "Refresh" trick does work, but it's still a little scary to see all the measures you painstakingly created suddenly disappear! It's now May and there's still no fix yet 😟


@v-lili6-msft it would be nice to see an official acknowledgement from Microsoft that they know about it and that it's on a bug list to be fixed...