Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Issue Desktop version (store) - Restore saved database error

Hi to all,


Just got the February 2020 version (Microsoft Store app) and got the error Unable to open document - We weren't able to restore the saved database to the model.


Been looking around the community and options go from unninstalling and then reinstalling, did that but still same issue.


Tried to install the February version standalone however the version available online for download is the December version (although says the upload was made in February 18th) everything works normally but it's not comparable.


Also read that for some previous versions were this happened there was a new install version that solved the issue.


Thanks for the attention.

Miguel Felix

Status: New
Frequent Visitor

Hi, the same problem.

Frequent Visitor

Same here

Advocate II

Same problem with really large files (2gb+).

Community Support

Hi all, 


The installation file in download center is version 2.78.5740.721 64-bit (February 2020). Please download and install it here to see if the same issue occurs. 


Best Regards,
Qiuyun Yu

Regular Visitor

Same issue with new version. 
@v-qiuyu-msft   - same problem left

Super User

Hi @v-qiuyu-msft ,


Even downloading the desktop version the error persist.


Be aware that I have tried this on another computer and everything is working properly.


This is happening on my work computer so now I have several models that I cannot do anything about especially because there are some features in the new version that will improve some work I have made.


Thanks for the assistance

Miguel Félix

Not applicable

Same Issue.

Yesterday everything worked fine (everything saved properly).

Also models from projects that I haven't worked on in a while don't open anymore.

I've also tried reinstalling PBI desktop version (both through app store and file-download) and the issue persists.

New Member

Same problem here from this morning even without installing the new version. What is going on?

Frequent Visitor

Yesterday I was able to download December version (2.76.5678.782) 64bit from download center and it works great now. So I'm afraid that problem is exactly with February version.

New Member

Thx @adeptus2008 . I can only see the latest version in the download center. Could you sen med a direct link?