Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Issue Desktop version (store) - Restore saved database error

Hi to all,


Just got the February 2020 version (Microsoft Store app) and got the error Unable to open document - We weren't able to restore the saved database to the model.


Been looking around the community and options go from unninstalling and then reinstalling, did that but still same issue.


Tried to install the February version standalone however the version available online for download is the December version (although says the upload was made in February 18th) everything works normally but it's not comparable.


Also read that for some previous versions were this happened there was a new install version that solved the issue.


Thanks for the attention.

Miguel Felix

Status: New
Not applicable

Having the same problem with a customer, installed the december 2019 version and now it works.

Not applicable

Same here!

Not applicable

Same problem here. Re-install did not help. Cant open any PBIX file.

Advocate I

Hi, Everyone.


Maybe someone has the problem I have: after I got Power BI Desktop February 2020 update (it was installed automatically through MS Store) an error message pops up and prevents me from changing any settings when I try to open any DQ report (credentials, connection settings and etc.). When I close this message, I get the new one in a second. It's just so annoying!


error message.png

Regular Visitor

Same here, and cannot install previous version as administrator rights not available.


Please fix it asap.



Regular Visitor

@MFelix  thanks, earlier versions work fine. Hopefully the issue will be fixed in a while.

Regular Visitor


Responsive Resident

@Anonymous , it seems that even the file you create with this version, you cannot open them after closing. 😕


Regular Visitor

Hello @Microsoft Team, 

what are the usual SLAs for those critical issues? (not being able to open pbix files is beyond critical 🙂 )


Thanks in advance for the update.

Regular Visitor

Thanks, we have the same issue, all users that had the newer version have been blocked since yesterday's release. finally,  re-installed the December version and this fixed the problems caused by the latest release