Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Gateway Connection and Data Source Credentials are missing from the Datasets Menu

Hi, I cannot set datasets refresh schedule. The error message "You can't schedule refresh for this dataset because the following data sources currently don't support refresh:" But there is no datasources listed. And also the Data Source Credentials items are not shown, so I don't know which data source has an error. 

 

tinna_0-1655103257307.png

When I manually refresh this Datasets, the status is completed.

tinna_1-1655103433065.png

Please help, thanks.

 

Status: Investigating

Hi @tinna ,

 

Are you adding a data source to the Manage Gateway page?
Can you update the gateway to the latest version or restart the gateway to see if the problem persists?

 

Best Regards,
Community Support Team _ Caitlyn

Comments
v-xiaoyan-msft
Community Support
Status changed to: Investigating

Hi @tinna ,

 

Are you adding a data source to the Manage Gateway page?
Can you update the gateway to the latest version or restart the gateway to see if the problem persists?

 

Best Regards,
Community Support Team _ Caitlyn

tinna
Regular Visitor

Hi @v-xiaoyan-msft ,

 

Thanks for your response.

Actually the datasource was added to the gateway for some time(almost a month) and everything was fine.

On weekend 6/11 the gateway machine was shutdown and I turned it on at 6/13. Since 6/13, some strange issues happen:

1. Some of my datasource cannot connect:  there two Web data source from my Sharepoint file and one PBI Dataset. Both with the same error message below.

2. The Gateway and Datasource Credentials items are missing from the Dataset menu.

 

Issue 1. Cannot connect to Sharepoint file and PBI Dataset

tinna_0-1655191019544.png

There are 3 files from Sharepoint that used in this Datasets, but 2 of them cannot connect (cannot adding the data source after deleted it because the gateway connection always return error-as above picture).

tinna_3-1655191594859.png

 

The 1st file Master_MO_KPI.xlsx status is online, it was located in the same location as the other two. But I am not sure that I can add it back if I delete this datasource.

tinna_6-1655192623311.png

 

Issue 2. The Gateway and Datasource Credentials items are missing

 

This case seems happen when one of the datasource of the current gateway used by the data set has an issue.

If the datasource used by the gateway has no issue(Dataset refresh completed), but the Gateway and Datasource Credentials are missing, I just need to refresh(F5) this Datasets page becomes normal and shows Gateway and Datasource Credentials.

tinna_4-1655192031550.png

After page refresh(press F5)

tinna_5-1655192114233.png

 

I have restart the on-premises personal gateway and the version now is 3000.114.6.

Btw, the gateway is using another AD account. This power bi datasource and sharepoint are using my AD account. I also installed on-premises in my own laptop and those sharepoint files can connect successfully.

But it was working fine using the gateway with another AD account, don't know why it cannot connect now.

 

Appreciate for your help.

 

Best regards,

Tinna