Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Dataflow Refresh - Internal Error


Since last friday i'm with some issues in refresh my datasets. Most of the the refreshes that we try returns an internal error:



Error: Internal error Request ID: ad8067f3-103b-4cde-a815-9869e2a3f98c Activity ID: 00000000-0000-0000-0000-000000000000




My dataflows are connected to Google BigQuery, with Powerbi Connector,  and this never happened in the past. 
the error always happens at different refresh times, different entities,  and happens on all the Dataflows we have on the server on the various PRO accounts.
Do you have any idea of what is happening for this error


Status: New
Advocate I

The problem is back since this mornig,
I don't have any refreshed finished with success

Regular Visitor

Same problem, intermittently, past week or so, with multiple dataflows.


This is occurring on my client's tenant, which is located in Europe North. If I replicate the dataflows on my own tenant (UK South) they work better.


Many of my dataflows are accessing Azure SQL. Interestingluy, if I watch server tasks on Azure SQL while the dataflow is refreshing, I can see that the data fetch part of the dataflows runs identically whether I locate on Europe N or UK S; however I think the issue is in the transformation or persistence part of the dataflow which happens once the data has been fetched.

Regular Visitor

Same issue with quite a few customers, refresh fails 9 out of 10 times. Worked all fine until April 28th. Issue seemed to be resolved with an update of the Gateway but since yesterday the problems are back again. I hope my customers can be a little more patient.


Once again our apologies for the issue. Dev team confirmed as of early this morning some of the issues are mitigated. Are the issues you are seeing yesterday or today? Thanks, Mahesh

Regular Visitor

Yesterday it was messy all day, today it seems to be running again since 14:00 CET, the last 2 scheduled refreshed have been working so I'm keeping my fingers crossed it continues like this for a little longer this time


Advocate I

hi @MaheshPrakriya,

It seems to be ok, The last 2 scheduled refreshes ran with success

Frequent Visitor


I can confirm it's still not working for us (north europe). Most of our refresh failed since the 13th of may...

Not applicable

We had this issue too, for all of our Azure Analysis Services. What solved the issue for us, was that apparently the appropriate authentication method changed. We have MFA enabled and to be able to get this to work, we always had to specify our username in the basic auth method option, where we could leave the password blank. After pressing 'sign in' we would be presented with the well-known Microsoft Account login popup and everything including MFA would work. But not from the May 2021 Update onwards. We now have to use the 'Microsoft account' option and sign-in from there.


Good luck everyone and post what worked for you here, please. If this solution works for you, please mark it as a solution, so others can find it in the abundance of 'me too' comments.

Regular Visitor

So far so good for us this morning - we are in the NCUS (North Central US) region. All our dataflow refreshes are completing as normal with the exception of just a few tables/entities taking a little longer than they should. We didn't do anything on our end to cause this to resolve.


Previously, all dataflows failed from Friday 5/14/2021 though all of Monday 5/17/2021 with the message "Error: User is not authorized to access the gateway".


Preceding that, we only received intermittent errors from 5/11/2021 through 5/13/2021 with the error message "Error: Internal error Request ID ..." with most of the scheduled refreshes completing successfully.

Let’s hope this is a stable resolution and not an intermittent one. I'll post back on this thread later today if we receive any additional errors that seem like red flags.

Frequent Visitor

Can confirm these issues are still being experienced today in Australia South-East.

90% of dataflows failing "Internal error...."