Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Data view not showing any values



When I am trying to view a table in the data view it is coming up blank, however if I go into the edit query it is bringing up the data and if I go to the filter it is bringing up data.  See screenshot attached.







Status: New
Microsoft Employee

Hm, sounds odd - is it blank for all tables in the model or just for the particular table?

You can try disabling the SemanticQuery in DataView:
1. Close the PowerBI Desktop

2. Open System Properties > Environment Variables

3. Add new user variable PBI_semanticQueryInDataView = 0 and close the Environment variables dialog

4. Start the PowerBI Desktop and try opening the same report.

5. If it doesn't help please remove the variable, otherwise remove it before next update.



Not applicable

Hi @varakcheev,


Was blank for one table, a data refresh seemed to clear the issue.





I'm getting the same issue on a number of tables and it only seems to happen since the new desktop update (with the data filter views). I've tried refreshing the tables and adding the user variable as described above but neither of these seem to work. The data seems to be there (like in the screenshot above, data values show in the filter and underneath in the status bar text) but just not showing. Anyone else have any ideas please?
Not applicable

this issue  still occuring for me. I tried adding environment variable and installed latest Power BI desktop version.

Regular Visitor

Even i am facing this issue recently the data view for some imported tables are completely empty ad for remaining tables is half empty but all the manually created tables in powerbi are being displayed correctly. If anyone knows the answer please help me with this issue. Thanks in advanced. 

Not applicable



I have a similar issue and, for my case, it was caused by the "Table" set up in Excel or the source.


You might want to check the following:

1. Scroll down to the bottom of the data, do you see your data?

2. Filter any of the columns (make sure uncheck the blank), are you able to bring out the data?

3. Sort any of the columns (say, A come first, and blank at the other end), are you able to bring out the data?


If you can see data in any of the above three conditions, it is possible that your "Table" in Excel (or other source) is bigger than necessary (say, you only needed 10k rows, but you provision for 50k rows"). What Power BI showings are all the blank rows, but the data are somewhat sorted to the end of the data view page.


Hope this helps.

Regular Visitor

to bring closure to this topic for everyone looking into this, as I also had the same issue:
@Capries @Anonymous @rsaprano 

If you notice in the initial screenshot, if you go to the data view and you select a columm dropdown, there is the value 'blank'. The same was happening for my fields, but I did not have any blank values in my connected Excel file. 

The solution was to close PowerBi, Open the connected excel and select all of the blank rows, rightclick and hit delete.

For me this happened because I built the powerbi on the same excel file, which was initially longer, but copied in a new list with new data, which was shorter, but only deleted the values. and so powerbi recognizes the lines still as part of the data table!

once done, open powerbi again, refresh the data and you should see it apair (as well as no longer having the 'blank' option in the colum dropdown of the data view)

Not applicable

Even I was facing the same issue. I was using an Excel as source. The Root Cause is the blank cells(rows or columns towards the end).


Fix: Create a new Sheet(Sheet2) in the excel and select the contents(ONLY contents, do not copy the blank rows or columns) from the Sheet1 to Sheet2. Delete the Sheet1. Now save the file and then connect from PBI Desktop to this excel as a new connection and then do the transformations and then close and apply.


This will fix the issue.


Hope it helps !!

Regular Visitor

I faced similar Issue, it was truly due to empty rows. i used "remove empty" in the power query to get back my data




Regular Visitor

I had the same issue. Turns out I imported way more rows than I needed. When I set the column to decending order, the data appeared. I solved by eliminating rows in Power Query