Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Bug The legend colors do not match what is in the Desktop - all legend items match the line color

For any existing "Line and Stacked column chart" or "Line and Clustered column chart", the legend colors do not match what is in the PBI Desktop.  In fact, every legend item matches the color of the Marker color under Shapes.  It was working as of yesterday 7/8/2020.  Here is the Desktop visual



Here is the same visual in the PBI Service




If I change the Marker color under Shapes, the legend colors change to its color




If I recreate the visual from scratch, it all works fine.  I am going to recreate every visual (there are many) but I thought you might want to know about this.  Cheers


Status: New
Community Support

@russfai ,


It's weird, I have made a test but couldn't reproduce your issue. The legend color is same in desktop and service as below, my tenent location: East US 2 (Virginia). If this issue persists, I would suggest you create a support ticket here for further analysis.

Support Ticket.gif 


Jimmy Tao

Advocate I

Same problem here from Norway. It worked yesterday, today all colors are blue in the service, but looks fine in desktop. 

Not applicable

Hello All,


I have the same issue with reports based on Multidimensional models.

Legend items are ignored for charts when Axis is filled with data items. The same color is used for all legend items and the legend shows only Measure name. 




Data Colors setting has only the first option from the list of legend items.


The issue started just today and occurs for multiple MD models and for all charts, even for reports created from scratch.




Not applicable

We have the same issue that Henmor is describing since this weekend. In PBI Service all hierarchical fields such as years etc. don't work in the legend anymore. It only sees the first value and displays it all as one category.


This is on SSAS by the way. Offline datasets do work.


This is a critical issue in a production environment, already sent out a ticket as well.



Not applicable

Same issue for us. Using SSAS MD as well.

Advocate I

@v-yuta-msft this is becoming a big issue for several now. Please look into it. Connected with Ssas, multidimentional cubes. 

Not applicable

Is there any support request created for the topic?

Shall we create a new one?

Not applicable

I created 120071325001424, but was not able to mark it as critical in the UI.

Not applicable

For information. I tried to update the gateway to the latest version (June 2020). The problem persists. 

Advocate I

Also tried to republish report from updated desktop, still same issue.