Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Bug: Datamart Loading Data Internal Error Code 500 - Failed Runtime Assertion

I was updating our datamart and was given the following Internal error message:

InternalError

  • ErrorMessage: An internal error happened due to failed runtime assertion: Unable to change Model locale after other objects have been created..
  • HttpStatusCode: 500

 

This also occurs when I haven't updated anything in the datamart and follow path Transform Data -> Save -> Error Message

Status: Needs Info

Hi @OHMark 

Do you have this problem with all your dataflow?

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
OHMark
Regular Visitor

Hello All!

 

@luizraposo is correct that the locale for me (English United Kingdom) is buggy. I switch to English United States and was able to load my datamart.

Steps to switch:

  1. Enter Datamart
  2. Trasnform Data and stay on the Home Tab
  3. Go Options -> Regional Settings
  4. Change your Locale to English United States
  5. Load Datamart - Should work

I tried switching back to English United Kingdom but it bugged out on me with the same error message. @v-yetao1-msft, Can this be resolved please as I'd prefer to stay on the English United Kingdom locale?

ivandavidbt
Frequent Visitor

Hi @OHMark , thank you for your guidance on changing the region, this solution is definitely not working for me. Are there any updates from the microsoft team @v-yetao1-msft ?

Thank you!

Dianis08
Regular Visitor

Thanks for the post @OHMark , the change worked for me, but in my case I changed from English United States to English Australia.

 

But Interested to know other solution.

 

Kind regards,

Mkin
Regular Visitor

Hello all!

 

I'm in the same boat as @ivandavidbt. I've tried changing the regional settings, but still get the same error code. If anyone knows of any other solutions, that would be greatly appreciated. 

 

Thank you!

luizraposo
Regular Visitor

guys, it's in this line of OhMark that I made the configuration and it worked first hand. I suggest running variations of "English" locales to find the correct one

sarah127583
Regular Visitor

Hi - same problem here - are there any solutions to this?

cedar
Frequent Visitor

Thanks @OHMark , I changed from English United States to English UK and it worked.