Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

[BigQuery] (310) Storage API Error: Error: { code: UNKNOWN, message: Stream removed }

I am getting this error for big projects which have large number of rows - 

 

Failed to save modifications to the server. Error returned: 'OLE DB or ODBC error: [DataSource.Error] ERROR [HY000] [Microsoft][BigQuery] (310) Storage API Error: Error: { code: UNKNOWN, message: Stream removed }. '.

 

And I am not using ODBC driver but Google Big Query connector to connect to GCP Big Query. Though I have ODBC Simba driver installed in my VM. What is the issue here?

 

I noticed one thing this error we are only facing in a shared vm(among 9 members). When I am working on a personal Azure vm then this error is not coming and data is also loading very fast. Both have same ram(32 GB) and cpu(xeon 8272cl vs 8370c) and are in same network zone. What can be issue here?

Status: Investigating

Hi  @songogeta32 ,

 

The error message indicates a which suggests there might be an issue with the data sourceitself. It’s possible that the data you’re trying to access is too large or complex for the connection to handle. You might want to consider optimizing your queries or reducing the amount of data you’re trying to pull in at once.
The difference in behavior between the shared VM and the personal Azure VM could be due to a variety of factors. Shared VMs in Azure allow you to attach a managed disk to multiple virtual machines (VMs) simultaneously. This could potentially lead to issues if multiple users are trying to access or modify the same data at the same time. On the other hand, a personal VM is dedicated to a single user, which might explain why you’re not encountering the same issues there. Since the error only occurs on the shared VM, it’s possible that network issues could be causing the problem. If the shared VM is experiencing high network traffic or latency, it could be timing out before the data can be fully retrieved.
Some users have reported that clearing the data load cache and permissions can resolve similar issues. You can do this by going to , then save the file and load againFile -> Options and Settings -> Options -> Data Load -> Clear Cache.

 

Best regards.
Community Support Team_Caitlyn

Comments
v-xiaoyan-msft
Community Support
Status changed to: Investigating

Hi  @songogeta32 ,

 

The error message indicates a which suggests there might be an issue with the data sourceitself. It’s possible that the data you’re trying to access is too large or complex for the connection to handle. You might want to consider optimizing your queries or reducing the amount of data you’re trying to pull in at once.
The difference in behavior between the shared VM and the personal Azure VM could be due to a variety of factors. Shared VMs in Azure allow you to attach a managed disk to multiple virtual machines (VMs) simultaneously. This could potentially lead to issues if multiple users are trying to access or modify the same data at the same time. On the other hand, a personal VM is dedicated to a single user, which might explain why you’re not encountering the same issues there. Since the error only occurs on the shared VM, it’s possible that network issues could be causing the problem. If the shared VM is experiencing high network traffic or latency, it could be timing out before the data can be fully retrieved.
Some users have reported that clearing the data load cache and permissions can resolve similar issues. You can do this by going to , then save the file and load againFile -> Options and Settings -> Options -> Data Load -> Clear Cache.

 

Best regards.
Community Support Team_Caitlyn

songogeta32
Helper I

@v-xiaoyan-msft  I noticed in shared vm windows version is 22621.2715 but in personal vm windows version is 22621.3296. Is there any fix in new windows updates?

Also powerBI in shared vm is new 2.127.1080.0

powerBI in new vm is new 2.122.746.0 

Can these differences create any problem while loading?

songogeta32
Helper I

@v-xiaoyan-msft  I had a discussion with Google Team. They know about the issue, they mentioned that on retry this can be solved easily. But it seems like the Google BQ connector doesnt have the retry mechanism. Is this being worked upon?