Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Unable to configure gateway connections for dataset

Hi,

I am unable to configure gateway connections for dataset for a pbix report uploaded. I have created data source connections prior to uploading the file. All the 23 data sources are on-prem.

When I tried to apply the gateway connections (all have green check marks), I got this error message:

Link0978_0-1670952960704.png

I also noticed this banner. The dataset does not have any cloud data souces:

Link0978_1-1670953073426.png

 

 

Edit:

@v-yetao1-msft 

I originally just uploaded the pbix file to the web portal. The file was built using the Power BI Desktop RS Jan 2022 version. Then I tried to open the pbix file in the RS Jan 2022 and published to our P1 capacity-backed workspace. The issue persists.

 

Then I opened the file in Power BI Desktop Oct 2022 for powerbi.com version. I saved the file and published it again. The issue persists.

 

Some of the data source connections are also used by other reports without an issue. The other connections were created just for this report.

The connections are consisted of SQL servers and file shares.

 

We have 2 windows 2016 VMs in a cluster to host the on-prem gateway. Version Aug 2022.

 

 

 

Status: Delivered

Hi @Link0978 

This issue has been fixed , I will change it to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
awright19
Frequent Visitor

I am having the same issue. I've uploaded a new dataset that won't let me connect to the gateway. It uses the same connections as several existing datasets that are working fine.

birknerj
Advocate I

I'm also experiencing this issue.

v-yetao1-msft
Community Support
Status changed to: Needs Info

Hi @Link0978 

How did you upload the report ? Pulish report from Desktop to Service ? Or get pbix file in Service directly ? Can your other datasets match the data source?

 

Best Regards,
Community Support Team _ Ailsa Tao

rbrocks
Advocate IV

A user in my organization entered a ticket with the same error happening. He has another dataset that has similar data sources and it is refreshing fine. But after selecting the gateway data sources for this new report and hitting apply he gets the same error. 

Anonymous
Not applicable

The same issue happens at my customer!

Link0978
Regular Visitor

@v-yetao1-msft 

Hi,

I updated the post to provide more info.

Anonymous
Not applicable

I am also experiencing this issue.  

AleFerreira
Regular Visitor

Does anyone get this fixed? I'm having the same issue here. I also use the same connections in others Datasets.

Link0978
Regular Visitor

It has not been fixed yet. I provided addtional information and waiting for response.

rbrocks
Advocate IV

I have submitted a support request through my company's Microsoft support plan. I included the link to this thread as well. Will update if I hear anything more.