Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Unable to configure gateway connections for dataset

Hi,

I am unable to configure gateway connections for dataset for a pbix report uploaded. I have created data source connections prior to uploading the file. All the 23 data sources are on-prem.

When I tried to apply the gateway connections (all have green check marks), I got this error message:

Link0978_0-1670952960704.png

I also noticed this banner. The dataset does not have any cloud data souces:

Link0978_1-1670953073426.png

 

 

Edit:

@v-yetao1-msft 

I originally just uploaded the pbix file to the web portal. The file was built using the Power BI Desktop RS Jan 2022 version. Then I tried to open the pbix file in the RS Jan 2022 and published to our P1 capacity-backed workspace. The issue persists.

 

Then I opened the file in Power BI Desktop Oct 2022 for powerbi.com version. I saved the file and published it again. The issue persists.

 

Some of the data source connections are also used by other reports without an issue. The other connections were created just for this report.

The connections are consisted of SQL servers and file shares.

 

We have 2 windows 2016 VMs in a cluster to host the on-prem gateway. Version Aug 2022.

 

 

 

Status: Delivered

Hi @Link0978 

This issue has been fixed , I will change it to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
ehernanz
Regular Visitor

Today, I'm working fine!

Anonymous
Not applicable

Works fine now.

Tks


felipe_souza
Frequent Visitor

Thanks!
I tested it and it worked perfectly.
It is not necessary to update the Gateway application.

v-yetao1-msft
Community Support
Status changed to: Delivered

Hi @Link0978 

This issue has been fixed , I will change it to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

AKaherl
Regular Visitor

Is anyone else still experiencing this? I just started having this issue today. I uploaded an existing dataset to a new workspace in order to test out some changes before loading out to our users and I'm getting this error:

AKaherl_0-1673474363411.png

 

When I try to assign the gateway, I can select the gateway from the dropdown but the apply button stays greyed out so I cannot successfully add the gateway and when trying to look at the data source credentials, nothing loads.

 

AKaherl_1-1673474463837.png

 

 

e26199
New Member

I am unable to open the dashboard