Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Relationship Lines Missing in Model Viewer in Version 2.119.701.0

All the relationship lines are missing from the model view.  All graphical manipulation of the model fails.  Adding new tables/datasources fail.  A new version needs to be released immediately.  It appears that version 2.119.666.0 doesn't have that problem.  These versions are so new that they're not even documented on the Microsoft site.  😞

 

Status: Accepted

Hi @cperuski 

It’s a known issue . The engineers are actively working on this issue and I will come back with an update if there is any progress.

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
Sachin_Kunal
New Member

As soon as I added new table ,relationship lines disappeared for all the tables and new table is not appearing on the model view .

All existing relationship is functional but lines disappeared .This need immediate fix

Balex
Regular Visitor

Having the same issue here, but worse. Once I import a new table and open modelviewer, it shows the table in the upper left corner, but unable to move it. Once I save the my pbix file and try to open Modelviewer again, it simply wont load and keeps processing. It will only show the modelviewer if I delete the new imported table...

v-yetao1-msft
Community Support

Hi @cperuski 

How did you get the version 2.119.701.0 ? The latest version I can download is 2.119.666.0 64-bit (July 2023) . I tested your issue with it and it's normally in my Desktop . 

I've provided my procedure so you can see if it agrees with you. If not, please provide your steps and screenshots of the problem.

Recording 2023-07-20 at 09.34.50.gif

Best Regards,
Community Support Team _ Ailsa Tao

Anonymous
Not applicable

@v-yetao1-msft I got this version by deinstalling PBI Desktop and downloading it again through the Microsoft Store.

You can reproduce it if you use a PBIX file which was created with an older version and add there a new table.

Creating a totally fresh PBIX with new version seems not to have this problem.

 

timmay
Advocate I

Yes, I have exactly the same problem.  I raised a support ticket and they told me to uninstall PBI and go back to the June or May version but I won't be doing that unless I really have to as I've already developed new visuals with the July features.

sanoopSuresh
New Member

Facing the same issue. All the relationship lines are missing in the dataset. 
Also noticed if you have a pbix file connected live to a dataset in the service, we can see the relationship lines of the dataset in the new file ( model view ) . This is helpful in referring the relationships until the issue is resolved.  

DDDDD
Frequent Visitor

@sanoopSuresh @timmay @Anonymous @Balex @Sachin_Kunal et al don't forget to vote this up, needs more priority 👍
@v-yetao1-msft when's this getting fixed??

Pat_msft
Employee

Can someone experiencing this issue try setting the following environment variable, restarting Power BI Desktop, and seeing if the issue continues:


Name: PBI_diagramLayoutWebWorker

Value: 0

 

You can also try to uninstall version 2.119.701.0 and reinstall the App from the store. The current latest version from the store should now be 2.119.666.0. 

uggitodorovic
New Member

I am experiencing the same issue. 

Anonymous
Not applicable

@Pat_msft  I uninstalled the verison 2.119.701.0.

Now the version 2.119.870.0 64-bit (Juli 2023) was installed by Microsoft Store --> still exactly same problems...
PBI Desktop is not usable since over a week.