Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Premium_ASWL_Error - Single sign-on (SSO) credential is not provided which is required to execute

{"error":{"code":"Premium_ASWL_Error","pbi.error":{"code":"Premium_ASWL_Error","parameters":{},"details":[{"code":"Premium_ASWL_Error_Details_Label","detail":{"type":1,"value":"Single sign-on (SSO) credential is not provided which is required to execute the current request."}}]}}}

Facing the error in composite model, Published the report with diff name and tried as well. 

Status: New
New Member

hi @RubanBasilea , can you please elaborate more on how you use Power Bi string connection (API connection) using Analysis service connector to solve this?

Frequent Visitor

Hey folks.


I've actually replicated all the steps and found out the following

1) Connecting to the existing dataset as DQ only - refresh from Service works perfectly

2) Connecting to the existing dataset as DQ and using Sharepoint Excel source as supporting data - refresh from Service works perfectly 

3) Connecting to the existing dataset and using Sharepoint Excel source as supporting data AND adding a virtual calculated DAX table based on the DQ dataset - This is where it fails to refresh, throwing the error indicated in the thread.

This needs to be resolved by Microsoft, what's the point of being able to connect to the dataset and NOT be able to create virtual tables and model the data further??


@RubanBasilea - could you elaborate on how did you connect via the API ? I'm facing issues on my end.

Helper II


If you are using Power BI service.  For every workspace you can find your connection string in the Dataset ( Schedule refresh) option.Please find in the below image.


If the link (URL) contains any additional indicator after ; please clean it.


Copy this Link connection and you can Directly go to Get Data  -> Analysis Service -> Paste the link.




@braventooth @febrinaawisata 

Frequent Visitor

@RubanBasilea  very cool! I can connect to the dataset this way.
However - Import / Live are the only options ; - )

Any way to DQ?

Helper II


Once connected with Live Connection . Try to connect some other sources like Excel or some other from Get data.


It will ask you to switch to local mode .... click ok.


Live connection will be change to Direct Query. 


Important: Dont forget to enable this option in Settings




Frequent Visitor

@RubanBasilea First of all, thank so much for taking time to answer the questions and trying to help, much appreciated.


As for the suggestions - Yeah, I have that preview feature enabled, and your method works when I connect to usual datasets in Azure Analytical Services for example, but for some reason - when I connect to dataset that sits in my workspace in Live mode as you suggested, using the API connector, other data sources become greyed out. In the bottom right corner in the taskbar where you can also click to change the model type from Live to DQ usually it only says 'Live connection: Connected' and its not interactable at all.


I tried other way around, first connecting to a different DQ dataset I know of, then trying to add the powerbi:// connection but it just literally does nothing 😃



Advocate I



Any update on this?

The same issue has been reported under other issues as well. E.g.

I'm really looking forward to a solution. Refreshing the pbix file locally on my desktop and then publishing is my current solution, but it really should be possible to just refresh online.



Frequent Visitor



Any update on this? I'm getting this same issue and I really need a calculated table referencing de DQ.

Not applicable

Getting the same issue
"Single sign-on (SSO) credential is not provided which is required to execute the current request. Note that performing a refresh over a dataset with a calculated table or a calculated column which references a Direct Query data source is not supported within the Power BI service."

I've cleared he dataset to which Im connecting from all calulated tables, columns and measures. Everything is done in PQuery. And all the actions are limited to basic table transformations, appending and joining.


In Desktop everything works flawlessly. All the standard (not private) gateways are up and running. Both datasets are published in PPU workspace. All the credentials are ok. And still I get the above error. 


Any idea when the feature will be fixed and available?


Frequent Visitor

Same issue her. Really hoope this will be solved.