Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Premium_ASWL_Error - Single sign-on (SSO) credential is not provided which is required to execute

{"error":{"code":"Premium_ASWL_Error","pbi.error":{"code":"Premium_ASWL_Error","parameters":{},"details":[{"code":"Premium_ASWL_Error_Details_Label","detail":{"type":1,"value":"Single sign-on (SSO) credential is not provided which is required to execute the current request."}}]}}}

Facing the error in composite model, Published the report with diff name and tried as well. 

Status: New
Advocate II

I couldn't find any documentation around this limitation. I understand composite model integration hasn't fully matured yet and bugs are to be expected. However, providing a feature in Desktop Mode and not on the service is blindsiding. I appreciate that the error message is very descriptive, however it would have been nice to be notified of this limitation in Desktop Mode when referencing the DQ in the calc table. Would appreciate an ETA for this fix. 


Thanks for all your hard work.

Advocate II

Hi, would appreciate an ETA on this fix.

Advocate II

Any updates?

Helper IV

Going by this thread it seems there is no way of putting a mixed storage dataset on a refresh schedule and Power BI doesn't seem to plan on fixing it.

Why even have the option if you can't refresh your dataset?

Microsoft Employee

We can refresh the model in service if we can remove the calculated tables in the direct query model

Helper IV

All calculated tables? So you can't even have a calendar table?

Not applicable

Had the same problem.

CALENDARAUTO seems to be working ok.

CT using other tables as a source lead to error.

So I had to move all data modifications into PowerQuery. Also had to switch to personal data gateway. 

Solves only part of my problems but nonetheless the composite report feeding on 5 PBI published datamodels works AND refreshes.

Created calculated tables in the report itself. Also works fine.



Helper I

seriously... unable to use directquery on other PBI datasets is just ridiculous...

Microsoft Employee

Remove the calculated tables created on top of Direct Query. It will resolve the issue

Regular Visitor

Hi everyone,


I have been encountering this today. I have been posting my current investigation details on this thread:


What I found interesting was the following:


I tried to change the configuration of the dataset on Power BI Services, and found something interesting.

I had someone else from the team taking over the dataset, and configuring the data source credentials (especially for the remote dataset), andit actually worked.


The permissions configured on the remote dataset are the same for the two accounts, so I am stucked in the understanding of this behaviour.


If someone has an idea, we can go further together!