Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Power Automate visual not loading

I am using the PBI Desktop Version: 2.99.621.0 64-bit (November 2021)

My power automate visual has suddenly stopped loading beyond this point. Is this issue faced by anyone else? I noticed this 2-3 days ago.





Status: Accepted


According to my research, a similar issue has been reported internally, so stay tuned. ICM: 273085537


According to the latest update, the developer team has found the root cause of this issue. Here’s the temporary workaround for this issue:


Customers can be mitigated by using Power BI web, as that can load the required iframes.


I will update here once I get any information.


Best Regards,

Community Support Team _Robert Qin

New Member

I am having this issue now both on the Desktop and the Web version. I just have spinning pin wheel when I go to edit. Has there been any movement on this issue?


I am having the same issue now. I checked both on the Desktop and the Web version are not working but have indefinate spinning wheel when I go to edit.


This should be considered a critical issue unless connecting Power BI and Power Automate is not a desired path indeed. 

Helper I

I'm still experiencing this issue (both latest desktop version & on web), despite being expected to deliver results based on the power automate visual. Is there any movement here??

Regular Visitor

*bump* same for me both Desktop and Web, on Version: 2.110.1161.0 Oct 2022

Frequent Visitor

Same for me, version: 2.112.603.0 64-bit (december 2022)
But on PowerBI online is seems to work.

New Member

Dear Microsoft Teams, Power Automate teams,


Please provide an answer and a remediation asap, it is blocking the daily activities (business) i have the same issue as well on the Desktop app and the Web version (December 2022).


Thanks for your help,


Version : 2.112.603.0 64-bit (December 2022)

Regular Visitor

This is actually quite absurd. I'm dead in the water on a project for our organization. I've tried everything, uninstalling PowerBI Desktop, reinstalling both x86 and x64. Deleting any cache files in Userdata folders. For a bit I was still able to trigger the flow from the button, but that's not working anymore now either. Editing from the Flow website is NOT a valid workaround because I can't access my PowerBI data set in the same way any longer. Luckily my project hadn't become mission critical to our operation "yet". Imagine if it had. This is "par for the course" with Microsoft, no concept of what a real-time mission critical application failure would look like to a customer's business. 

Regular Visitor

An update. When the file is uploaded to our PowerBI service in the cloud, you can go in and get to the same interface for editing where the PowerBI data elements are easily addressed etc. It still won't open in the desktop file, but at least I can get to the interface this way. You can do most of your editing through Power Automate online Flows, but you can't add a button and do certain editing functions if this is broken in the desktop client. Hope this helps anyone that has been held up this major bug!

New Member

I am facing the same issue with my Power Bi Desktop




Consequently, I tried using Power Bi services and it worked well. However, in power bi services, I am unable to 'Get Data'. Any solution please?


Frequent Visitor

Same here

On Version: 2.114.664.0 64-bit (February 2023).


Works on Power BI Service but a massive pain try to get anything done efficiently.