Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Missing data when using Cube.AttributeMemberID (July 2022 version)

Beginning today, I am receiving no data when connecting to SAP HANA and using the Cube.AttributeMemberID function in Power Query on a field. Could this be an issue with the July 2022 version? Or do I need to modify the Power Query some how? There is no error given during refresh, the column is just blank in the resulting dataset. 

Status: Delivered

This issue has been fixed in Power BI Desktop August 2022 version 2.108.997.0(Download Microsoft Power BI Desktop from Official Microsoft Download Center).

Comments
JIP
Regular Visitor

Yes, seems we have the same issue

Mark_J
New Member

Unfortunately we are experiencing the same issue. Hopefully there is a quick fix as this has a significant affect on our reporting.

Anonymous
Not applicable

We are getting the same issue

breannajamieson
New Member

Same issue here too

S_C1
New Member

Experiencing the same issue. Hoping for a quick resolution.

free_the_data
New Member

Same issue here. 

Anonymous
Not applicable

This is also an issue for us

v-cazheng-msft
Community Support
Status changed to: Investigating

Hi @ABaker1 @Anonymous @free_the_data @S_C1 @breannajamieson ,

 

May I know whether you still have this problem? If it still happens, could you please provide the following info so I can report it internally to the product group? Thanks in advance!

1 The version number of your July 2022 Power BI Desktop, you could check it by following the screenshot

vcazhengmsft_0-1658204012595.png

 

2 Info of this issue including the data source type, connection mode, connector used, slice of data and applied steps.

It couldn’t better that you provide a download link of a sample pbix file that contains this issue if it is convenient for you.

 

3 The steps of reproducing this issue and the screenshot of the result of each step

 

4 Try with older versions to see whether this issue will take place and let me know the version numbers that can work properly

Previous monthly updates to Power BI Desktop and the Power BI service - Power BI | Microsoft Docs

 

Best Regards,

Community Support Team _ Caiyun

JIP
Regular Visitor

Thanks kindly for looking into this issue.

1. 

JIP_0-1658206161999.png

2. & 3.

JIP_1-1658206401346.png

3. custom column output

JIP_2-1658206486891.png

 

Please note that the previous version was working.  I have a .pbix file that was last updated 11/7/22 that is correct, but I am not sure when the PBI desktop update was distributed to us.

 

The only work around tested is to use SAP HANA connector with sql instead.

 

 

Ashley101
Regular Visitor

Same issue here