Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

May 2021 Gateway Error: SharePoint: Request failed: The underlying connection was closed.

Some where around May 13th, all of our datasets that connect to SharePoint O365 started failing with the following message: Unable to connect to the data source undefined. (Details below). On May 16th we upgraded our gateway to the latest May 2021 gateway which was version 3000.82.2 (Maybe .4) and everything worked for a couple of days. Then on the 19th we noticed it was failing again. We noticed that the gateway download for May 2021 had a new release and was now at version 3000.82.6. So we downloaded and installed and it seemd to resolve the issue. However, we are still seeing it fail. This morning it failed, so then I was able to manually refresh and it worked, however, it just failed again for the scheduled refresh and a manual refresh is also not working. Ideas? Thoughts? What's going on? Not sure what to do. 

 

 

Underlying error code:-2147467259
Underlying error message:SharePoint: Request failed: The underlying connection was closed: An unexpected error occurred on a send.
DM_ErrorDetailNameCode_UnderlyingHResult:-2147467259
Microsoft.Data.Mashup.ValueError.DataSourceKind:SharePoint
Microsoft.Data.Mashup.ValueError.DataSourcePath:https://sharepoint.com/oursite
Microsoft.Data.Mashup.ValueError.Reason:DataSource.Error
Cluster URI:WABI-US-NORTH-CENTRAL-redirect.analysis.windows.net
Activity ID:0b95ab8e-3780-4df9-9af1-7d2edd5cfd55
Request ID:1464c48e-1da5-ed3e-d5a3-956abbbc3971
Time:2021-05-21 21:42:35Z
Status: New
Comments
HuanYang
Regular Visitor

The same error on my side.

 

My friends point that, this is caused by the deprecation of TLS 1.0/1.1 by MS. Their connection failed from Server 2012 R2 to O365, since last week. At the same time, this issue happened on Power BI Services, so, @v-chuncz-msft, could you let Power BI team check the TLS settings on Power BI Services, and upgrade to 1.2 if it's lower. 

Another solution I can thought, is to use a gateway which installed on Windows Server 2016/Windows 10. 

Edyplou
New Member

I have the same issue with sharepoint connections, only when a SQL gateway is also present in the dataset to be updated.  

Anonymous
Not applicable

We have the same issue.

 

It only happens on a join of a Sharepoint file with a source comming from the enterprise gateway hosted on a Windows Server 2016 machine. 

 

Here's our findings so far : 

 

  • Gateway : We've tryed it on a personal gateway or with a standard gateway installed on a windows 10 laptop : no problem. We've suspected the HTTPS mode, but not conclusive.  Only fails on the Windows Server 2016 machine, with june 2021 and May 2021 release 2 gateway. Havent tryed other server.
  • Sources : If it's diffferent sources, all managed by the gateway, it's fine. Loading Gateway sources and Sharepoint without a merge works fine also. Only a merge of a source managed by the gateway with a sharepoint file fails. 
  • Security levels : We've verified that. All sources security levels are the same. We've tested to switch them all on public or org : non conclusive, still not refreshing.
  • Success rate : On very small datasets used for test, it would sometime finish the refresh with 29% success rate. Don't know why. On real size datasets, success rate is 0%. 

A ticket was created with Microsoft.

 

Will keep you posted when we find something. 

 

SELECTDBA
Advocate I

I've had a ticket in with Microsoft for three weeks and I am not making much progress with them.  I have done 100% of the troubleshooting so far, and you all are correct, its related to the TLS changes on SharePoint.  I found this article (https://docs.microsoft.com/en-us/sharepoint/troubleshoot/administration/authentication-errors-tls12-...) so I wonder if you all are facing an issue with the cipher suites?  You can use a really convienent tool called IIS Crypto to check and/or change your TLS/cipher suites.  

 

A note to Microsoft, this is getting fairly ridiculious that you're not acknowledging this issue and helping to resolve it.  

Anonymous
Not applicable

I am having the same issue from May 2021 up to current.

 

Underlying error code: -2147467259
Underlying error message: SharePoint: Request failed: The underlying connection was closed: An unexpected error occurred on a send.
DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259
Microsoft.Data.Mashup.ValueError.DataSourceKind: SharePoint
Microsoft.Data.Mashup.ValueError.Reason: DataSource.Error
Cluster URI: WABI-US-EAST2-redirect.analysis.windows.net
Activity ID: 590dea9c-9cf0-4e6a-89a9-59bdb1555299
Request ID: aac6a4c9-33eb-412f-a5fa-192c39dd6963
Time: 2021-06-08 15:08:35Z

chrisweis
Regular Visitor

UPDATE: We installed Power BI Desktop on the gateway server and were able to recreate the error on only the Win 2012 R2 gateway node.  This problem seems to be rooted in the Win 2012 R2 OS and its limited ciphers. We're abandoning that old OS, building out a new cluster node, and seem to have a path toward resolution.  Multiple Microsoft support tickets and technicians - we've been routed from the Power BI team to SharePoint Online to Windows server team.  The Windows server support team has a great BAT script that harvests most of the pertinent OS configuration details durung the error that they use for offline diagnosis.  Correction to my screenshot below: The Win 2016 Prod server did NOT have the error.

-------------------

 

We are also having the same problem.  Summary of our gateway configuration:

 

chrisweis_0-1623271217055.png

Findings so far:

  • The error occurs when blending on-premises data (SQL Server, Oracle) with SharePoint Online data
  • The problem doesn't occur on our older (November 2020) non-clustered gateway machine
  • The problem doesn't occur on Win 2016 server (as mentioned above in this thread)
  • Our gateway can connect fine to SharePoint Online (a SharePoint-only connection succeeds)
econzemius
Regular Visitor

We are having the same issue with Sharepoint based Excel files

CP0822
New Member

Hi,

 

Is there any news about this? I cannot connect to SharePoint lists using Power Query I tried with PowerBi and Excel and I always get this error

 

CP0822_0-1624254509787.png

 

Anonymous
Not applicable

As an update :

- Still trying to identify the cause with Microsoft.

- As a way to bypass this situation, we are building dataflows for Sharepoint sources, then using them to feed our models so that merges don't fails.

ecampschroer
New Member

As stated in an above link https://docs.microsoft.com/en-us/sharepoint/troubleshoot/administration/authentication-errors-tls12-...

Sharepoint has moved to tls1.2

 

What nobody mentiones is the cyphersuites microsoft is using for sharepoint.

For TLS 1.2, the following cipher suites are supported by Azure Front Door:

  • TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
  • TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_DHE_RSA_WITH_AES_128_GCM_SHA256

these cypher suites are probably not in use on your server where the gateway is installed.

at least our server didn't have those.

 

I added these cypersuites rebooted the gateway server, and o wonder it works.