Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Links to Published Power BI Report on Server Don't Work From Microsoft Word or Excel

Something strange.  A link that is known to be valid, when clicked, doesn't take the user to the report itself.  Rather, it takes users to the Power BI login page.  This behavior takes place from Microsoft Word and Excel.  However, the same link from Microsoft Teams or Outlook, when clicked, takes you directly to the report itself bypassing the login page.  This is the desired behavior.  Both sets of responses are observed repeatibly. 


I think this represents a bug.  A link, whether it's valid or not, should take you to the same place whether it's clicked from Word, Excel, Teams, Outlook, or really any other program.  I'd like to submit the behavior for bug research, please.

Status: New
Regular Visitor

We are experiencing the same with all of our Power BI reports when using chrome (Firefox and Edge seem to work as they did in the past.) 


We can get it to work if, from the Power BI home page,  we click Power BI service and login; the report will work next time it the url is clicked.   Or  logging into in one of browser tabs, works too.

  The login re-direct seems to have changed.

This started last week for us.


Please advise.

Not applicable

OK here's some more information:  


  1. I noticed that sometimes the links work from Word and Excel.  If you don't have a web browser open that has already logged you into Power BI, clicking the link will take you directly to the report.  However, if you already have a tab open that is at, or if you've had a tab open already on the session that the link loads to, you will be taken to the login page.
  2. I tried Microsoft Edge instead.  I get the exact same behavior with Edge.
  3. Outlook still doesn't take you to the login page no matter if it's the first time/subsequent time.
Regular Visitor

Do your links work if you add a UPN parameter at the end of the string?    "?"

Community Support



You may try adding "?noSignUpCheck=1" to the URL.

Not applicable

@v-chuncz-msft.  Thanks for the tip!  Adding "?noSignUpCheck=1" to the end of each URL resolved it!