Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Intermittent refresh failures: Data source timed out

I was asked to re-post this into this specific forum:


We are struggling with intermittent refresh failures. These failures occur across two different On-Premise Data gateway servers that we have.  We have scheduled refreshes running all the time, against many different data sources (SQL DBs, Oracle DBs, ODBC connects etc) many times they work and other times they simply fail with this error message.  It does not seem to matter which data source or which Gateway, we continue see intermittent failures of this type. 


Refreshes from Power-BI desktop do not have refresh issues.


We have logging enabled on both Gateways but thus far, have not really found anything useful in helping identify the issue.


We are using HTTPS mode on both Gateways


Failure can happen both with schedule refresh and using the "refresh now" button


 Has anyone else run into issues like this?


Last refresh failed: Thu Mar 28 2019 09:03:02 GMT-0600 (Mountain Daylight Time) 
Before the data import for BACK QUERY - ALL TYPES finished, its data source timed out. Double-check whether that data source can process import queries, and if it can, try again.


Cluster URI:

Activity ID:


Request ID:



2019-03-28 15:03:2Z

Status: New
Not applicable

We are having the same issue.  I was monitoring our SQL server and all the queries ran and appear to have finished, then the dataset sits there spinning in the PBI servce before producing that error message.   We also get a few others:


"Unable to connect to the data source undefined."
 - Odd becasue the data source is defined and succeeds at other times

"Before the data import for finished, its data source timed out.  Double check whether that data source can process import queries, and if it can, try again."

 - This one is odd because it doesn't specify the dataset in the first sentence...

Community Support

Hi @Anonymous, 


As you are using Power BI government, I would suggest you create a Support ticket to get help: 


Support Ticket.gif


@Anonymous If you are using commercial Power BI, please post a new thread with detail error information, eg: RequestID, ClusterURL. 


Best Regards,
Qiuyun Yu 

Regular Visitor

We have experienced this issue 3-4 times. The workaround I was given is the following and it works for us:

  1. Edit your report, in settings/options delete the data cache
  2. Save your report to My Workspace
  3. Perform a manual refresh there, if the report refreshes FINE then redeploy the report again to the correct workspace.  This fixes caching issues
Regular Visitor

We are getting the same error all the time when trying to refresh the data in PBI Service. In Power BI Desktop data refreshes without any issues. 


Error message: "Before the data import for table finished, its data source timed out. Double-check whether that data source can process import queries, and if it can, try again."


Is this issue related to the gataway? 

Not applicable

@Kalvis I would like to know the same thing!  We have spent alot of time focused the Gateway to no avail. Logs, perf counters, event logs, version upgrades etc...we have found nothing definitive. We even spun up a second gateway server and moved problem reports to it, only to find the same timeout issue persists.  


I am now looking at Fiddler as an option to troublehshoot but digging through that rabbit hole is going to take some time. Needle in a haystack type troubleshooting.


There is not alot of info here but this is the Microsoft artical that mentions Fiddler:


Not applicable

Also, the Capacity Metrics app might help some people troubleshoot.  This app is not available to me because I run a government capacity which has limitations. Most people with a premium capacity will not be running a government domain and this app should be available to you.  Maybe its helpful....



Not applicable

We are facing similar issue - "Unable to connect to the data source undefined."

Created a support ticket and waiting for resolution. As per MS Support recommendation updated the Gateway to latest version 3000.2.252. However after few days, the latest version available of MS portal appears as 3000.1.257. It seems there are issues with the Gateway release and not sure which one to use. 

Anyone facing similar issue?

Not applicable

Did upgrading help?  MS told us the same thing, but none of the updates made any difference, so much so that we are not prioritizing upgrades anymore.  We run upgrades, its not a priority as they don’t really seem to help this issue.

Not applicable

@Anonymous - updating for us made a HUGE difference.  Along with a few other minor changes, we reduced our failure count from 50+ per week and are now down to less than 5 this week from these issues.

Edited for grammar. 

Not applicable

Hi all,


I have been having the same error ("Before the data import for ... finished, its data source timed out. Double-check whether that data source can process import queries, and if it can, try again.") with my scheduled or manual refreshes for months and tried all possible things but no solution.

Today I have tried to disable all RDP connections on the workstation where the Gateway is installed so no secondary users would log in to that PC. Since then I had no fails.

Discalimer, my Gateway is installed on a PC running Windows 10 Pro and I had the exact same issue when it was on a Win7Pro.

I will let it run a longer cycle to confirm that my issue is gone for good. If it's not I will just delete this post.