Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started


Int32 Error when Refreshing Data Table

Hey, I am attempting to refresh our data source, but I run into an error that looks like this:


Error Message:

JSON integer 4294967295 is too large or small for an Int32. Path '[8].MaxLength', line 1, position 3149.


I am not sure where this is pulling from. It seems when I go through and individuall try to refresh tables, the error occurs from a table that is connected to an external DB.


What does this error mean and where is it originating from in PowerBI?

Status: Delivered

Thanks @jasonbub_seasi  and @marcjb  sharing the solution about this issue which would help users on the community who may have the same issue:


Users can try Detect Data Types in Power Query Editor before loading data into Power BI Desktop.


Best Regards,
Community Support Team _ Yingjie Li

Community Support
Status changed to: Delivered

The max value for int32 data type is 2,147,483,647 while your data is 4,294,967,295 which is too large to this data type.


You can try to change the data type to int64 type which data range is from -9,223,372,036,854,775,808 to +9,223,372,036,854,775,807


Best Regards,
Community Support Team _ Yingjie Li

New Member

I have the same problem : 

Error Message:
JSON integer 4294967295 is too large or small for an Int32. Path '[5].MaxLength', line 1, position 2007 and can't solve it with this solution

Not applicable

I'm facing the same issue. Started two days ago.

None of my rows contains the value 4294967295, but the tables causing the issues do have columns of type BigInt. The maximum size of a BigInt is 4294967295. It looks like power BI crashes on parsing the table definition, rather than the actual table data.

We have made no recent changes to the table definitions. Bug in Power BI?


Regular Visitor

Cordia saludos.


Desde ayer no he podido actualizar la fuenta de la base de datos, me sale el mismo error de los compañeros:


JSON integer 4294967295 is too large or small for an Int32. Path '[5].MaxLength', line 1, position 2038.


Alguien me puede ayudar,.



Helper II

I have the same problem accessing tables and refreshing data from a mysql database. It was working fine and stopped working and I had not made any changes. I believe it started with the June update.

It is happening to all of my files that access this database. I even get this error message in Desktop when - in a new file - I try to access ANY of the data tables ---- even something as simple as a Brand table (Brand names and IDs --- no large number sets).

Strangely, my published reports are performing scheduled refreshes properly.

It's only a problem in Desktop.

BTW - all other pbix files with other customers - accessing sharepoint sites or excel datasets are working properly.

Please help - this is a stop work issue - for me and my customer.

New Member

Same problem when update.  Two similar .pbix with two diferents mySQL databases.


More error details:




No problem when you update in Power Query, only in Desktop june update.

New Member

@v-yingjl your solution is marked "Delivered" but does not solve the issue. This appears to be an actual bug in PowerBI as it is happening to multiple users w/ MySQL connections not an actual Int32/Int64 discrepency as you suggested.


I am also experiencing the same issues described above.

New Member



A solution has been found.  See below.


I can confirm that this is also happening to me.  It just started yesterday.  I had refreshed this data set many times before yesterday and it worked just fine.  I don't recall updating PowerBI, but I may have forgotten doing it.


This is the error:

Error Message:
JSON integer 4294967295 is too large or small for an Int32. Path '[33].MaxLength', line 1, position 12296.


This is the version:

Version: 2.106.582.0 64-bit (June 2022


Database: MySQL 5.7


SOLUTION: (referenced by: @dgw_REA here:


  1. Go to Transform Data
  2. Select all Columns in your data set
  3. Click Transform > Detect Data Types
  4. Close and Apply
  5. Refresh Data



New Member


This seems to be from an update.
The problem seems to be:
Data_type = longtext

All other field formats seem OK.

Either change field type or select field in power query and press 'detect data type'

Regular Visitor

I'm using Power BI to generate DashBoards from a My SQL DB and so far everything was fine. But overnight, it gave me the following error message when updating:  hospede clientes - JSON integer 4294967295 is too large or small for Int32. Caminho '[35].MaxLength', linha 1, posição 12979.

I also saw that it quotes a "position", but I don't know how I can find it within Power BI. Does anyone have a suggestion on how I can proceed? Can I find this problem by transforming the data (step before loading the data)?