Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Dataset refresh error on Service

Hello Team,

 

My Power Bi dataset is not getting refreshed from yesterday. I have found out the issue is with Dataset that contains the Power Bi Dataflow (Legacy) connection sources.

 

It is throwing the error as "Access token has expired, resubmit with a new access token.". However, there is no issue when we go ahead with Power Bi desktop refresh.

 

The issue is not only with one dataset. The issue reasons are changing time to time. The same datasets were OKAY till yesterday evening GST.

 

Attaching the error messages for your reference.

 

shabeer_1-1688631321024.png

 

 

shabeer_0-1688631280120.png

 

 

Best Rag,

Shabeer M P

Status: Accepted

Hi @shabeer 

It’s a known issue . The engineers are actively working on this issue and I will come back with an update if there is any progress.

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
Sudheer_pathela
New Member

@v-yetao1-msft          .. Any update on the error? 

CollinCrossie
Regular Visitor

Seems to have cleared up on our side

mroark
Regular Visitor

Yes us too.

Sudheer_pathela
New Member
Data source error:Still having the same issue.. 

{"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"Access token has expired, resubmit with a new access token"}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.Error","detail":{"type":1,"value":"error \"Microsoft.Mashup.Engine1.Runtime.ValueException: [Expression.Error] The field 'pbi.error' of the record wasn't found.#(cr)#(lf) at Microsoft.Mashup.Engine1.Language.ValueCreator.CreateValueForThrow(IThrowExpression throwExpr)#(cr)#(lf) at Microsoft.Mashup.Engine1.Language.ValueCreator.<>c__DisplayClass23_0.<CreateValueForRecord>b__0(Int32 index)#(cr)#(lf) at Microsoft.Mashup.Engine1.Runtime.RecordValue.DemandRecordValue.get_Item(Int32 index)#(cr)#(lf) at Microsoft.Data.Mashup.ProviderCommon.MashupResource.TryGetValue(Func`1 getValue, IValue& value, String& errorMessage)#(cr)#(lf)Record\""}},{"code":"Microsoft.Data.Mashup.ValueError.Reason","detail":{"type":1,"value":"TokenExpired"}},{"code":"Microsoft.Data.Mashup.ValueError.RequestId","detail":{"type":1,"value":"a9219389-f719-48ae-91db-b170a2768827"}},{"code":"Microsoft.Data.Mashup.ValueError.RequestUrl","detail":"exceptionCulprit":1}
Table: everytime the table changes.. 
dtjdtj
Advocate I

What's the progress with this 'known issue'? It seems to be an unsolved issue for few months so far, could you please add it here so we can track its status?

egnvictorfarias
New Member

     Hi, I managed to solve it!

 Despite appearing online (gateway test), it wasn't working: the problem started after I was 'forced' to change my office365 password, I edited the 2 Gateways and confirmed my credentials.

 

egnvictorfarias_0-1703615082424.png

egnvictorfarias_0-1703615780887.png

 

 

  I just clicked edit and confirmed the credentials. Then I tried refreshing the dataset and it worked.

 This must be done for each gateway that has credentials (file/folder/etc)