Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Dataflow causing Gateway Configuration Bug

This is only a recent problem I am facing.

 

When I use a dataflow in a report/dataset, it refreshes ok within PowerBi desktop. When I publish to the service, the dataflow causes the gateway to be "Not configured correctly"

 

What is causing this problem?

Capture.JPG


Status: Investigating

With regards to a dataflow, you will have to first refresh the dataflow to get the new data in, before you refresh your Power BI dataset.

 

You can set schedule refresh for this dataset and check the refresh history whether it is completed.

 

Best Regards,
Community Support Team _ Yingjie Li

Comments
v-yingjl
Community Support
Status changed to: Investigating

With regards to a dataflow, you will have to first refresh the dataflow to get the new data in, before you refresh your Power BI dataset.

 

You can set schedule refresh for this dataset and check the refresh history whether it is completed.

 

Best Regards,
Community Support Team _ Yingjie Li

Anonymous
Not applicable

The dataflow and the datset in this case have been refreshing without issues for about 9 months. I have the same problem with other datasets that use dataflows as a source. I have tried everything that has been suggested within the community. Gateways are updated as soon as the new updates are available. 

Anonymous
Not applicable

Hello, is there an update here?

jesus21282
Frequent Visitor

Hi, please see my latest comment here, where we solved the issue:

Solved: Re: Gateway extenionDataSourceKind Power BI error - Microsoft Power BI Community