Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Dataflow Refresh Failures

Dataflow refresh is quite unpredictable.


Today I could refresh three dataflows in one workspace without an error (although one dataflow needed a retry). But I could not refresh three other dataflows with exactly the same entities and the same queries in another workspace . Sadly, the latter workspace is our production environment, so we are in trouble right now.


Whenever I saved changes after an edit, even if I did not change anything, the dataflow might or might not refresh. Sometimes it fails with an 'Internal Error', sometimes with a 2 hour time limit exceeded after 10 minutes? Sometimes editing and saving without changes fixes the issue, sometimes refreshing under another account. But now none of these actions changes the behaviour of the dataflows; they will not refresh anymore. Even worse, from our point of view there does not seem to be any logic behind the occurences or absence of refresh failures.


We switched to dataflows because they should be past the preview phase by now, and they seemed a good solution. We develop our queries in Power BI Desktop, to minimise the number of changes on the actual dataflows. Hence it is still possible to replace all dataflows with the queries from this file using the original data sources. But that requires a lot of rework on all the datasets behind the (already published) reports.


Has anyone simular experiences with dataflows? Does anybody know a remedy for this eractic hebaviour?

Status: New
Community Support

Hi all, 


Please check if these dataflows reside in a premium capacity. If it is, it's the same issue as this one in Support site. 




Best Regards,
Qiuyun Yu

Advocate I



I'm not on the premium capacity. Also after adding a new step in my dataflow, it seems to be incompatible with PowerBI version 2.73. I cannot "see" the dataflows anymore.

Advocate II

My dataflows are now refreshing correctly, as of yesterday early morning. Microsoft have closed my support ticket. They said the issue was about SharePoint data connections, although I had a dataflow which was affected, that only had Oracle connection and linked dataflows.


We're not on Premium either. Thankfully for us, everything is working as it should be. However I am concerned that it may happen again, at any time.

Regular Visitor

On 25th and 26th feb 2020 morning (between 6:00 UTC to 07:00 UTC) all my scheduled Dataflows from SharePoint (in PRO version) ran normally, with normal refresh durations (from 2 min to 30 min).

All seems to be ok now 🙂

Nota : I checked the valid credentials. For one specific Dataflow, we had an error caused by an invalid credential in an Excel 2013 file used as a data source. This was causing an error in PQ online, but not in Desktop version.  

Not applicable

Since yesterday all my Dataflow refreshes have been running successfully with normal durations as well.

(Pro version, most Dataflows are connected to SharePoint).


Credentials were ok. Whatever you did, Microsoft, worked. Thank you.

Not applicable

Hi everyone, I'm having a similar problem.

In the edit mode, the preview never finish the evaluation.

I tried both using super simple queries (like SELECT 1) and "Enter Data", but both queries take 10+ minutes to give a preview, if they give any.


I don't know if it is related, but I find this behaviour in a WS which is not in Premium or Dedicated Storage, but which was working fine up to yesterday.


Today I am unable to use the DF solution at all

DF Error.JPG


Thanks for your help

Not applicable



I was informed by our MS support team that a fix for SharePoint.Folder() connector was deployed this past weekend. Another fix for dataflows general "Lock Error" shall be deployed 3/5. 

Will monitor for any improvements.