Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Dataflow Error: Access token has expired resubmit with a new access token

I'm trying to create a transformation dataflow from a staging dataflow. 
The staging dataflow contains a big volume of data and refreshes fine.
In the transformation dataflow I'm trying to group and aggregate the staging dataflow.
I'm getting this error after an hour or so:

[DM_ErrorDetailNameCode_UnderlyingErrorMessage]=<ccon>Access token has expired resubmit with a new access token</ccon> [DM_ErrorDetailNameCode_UnderlyingHResult]=-2147467259 [Microsoft.Data.Mashup.ValueError.Error]=error "Microsoft.Mashup.Engine1.Runtime.ValueException: [Expression.Error] The field 'pbi.error' of the record wasn't found.#(cr)#(lf) at Microsoft.Mashup.Engine1.Language.ValueCreator.CreateValueForThrow(IThrowExpression throwExpr)#(cr)#(lf) at Microsoft.Mashup.Engine1.Language.ValueCreator.<>c__DisplayClass23_0.<CreateValueForRecord>b__0(Int32 index)#(cr)#(lf) at Microsoft.Mashup.Engine1.Runtime.RecordValue.DemandRecordValue.get_Item(Int32 index)#(cr)#(lf) at Microsoft.Data.Mashup.ProviderCommon.MashupResource.TryGetValue(Func`1 getValue IValue& value String& errorMessage)#(cr)#(lf)Record" [Microsoft.Data.Mashup.ValueError.Reason]=TokenExpired

How can I solve this?

Status: Investigating

Hi @gp10 ,


We've found feedback from other users who have had similar experiences to yours. Here are some suggestions from the PG team Please see if this mitigates your problem.

"Customer appears to be using Feb 2023 version of the gateway. Can you please ask the customer to upgrade gateway to the latest version and re-capture gateway logs? There were some changes in the token refresh implementation in Jan 2023, upgrading will assure we have the latest version being used. Also ensure only one version of the gateway is installed.


Customer should also consider removing all existing credentials to the dataflow and recreating them. Sometimes that can fix authentication problems in PBI service."


Best regards.
Community Support Team_ Caitlyn

Frequent Visitor

I was able to solve it by following these steps:


1: create a new power platform dataflow.

2: under connection details, click "edit connection" and sign in (again). 

3: I chose a random dataflow under the same workspace as my production dataflows. 

4: saved the dataflow.

5: opened the dataflow with erros and stepped through the dataset. No more error, hit save, and refreshed. 

6: deleted random dataflow from step 4. 


New Member

@gp10 @v-xiaoyan-msft Any resolution to this? @TDargan I have edited the data set and stepped through the errors multiple times. Each time it solves the problem, until the next refresh. Then a different data source fails. The problem is not related to a specific datasource or set of credentials, the failure seems to be random.

Regular Visitor

@gp10 @v-xiaoyan-msft Any update? I am also having same issues!

New Member

@gp10 @snalla123 @gzumberge @TDargan @aeriksen 


Hi all.


I had this same issue today and it seems I could fix it. I don't know if in the next refresh I will have the same problem though.


1. First, I opened the dataflow, clicked on "Edit tables" and went to "Options" to make sure the gateway I'm using is "None", since my data sources are other dataflows. Then I saved it.


2. I opened the dataflow settings > Data Source Credentials > Edit credentials > and then I signed in.


Before these steps I got the error with 2 hours of refreshing. Now, it loaded successfully in 3h30m. 


I hope it helps you as well.



Regular Visitor

@j_pereira NO, Mine issue is different, If I run manually it runs sucessful, but If I run through Azure data factory it is giving your token expired.



Power Participant

I have also started getting this problem as of 30th June 2023. I cannot create or amend a new DataFlow data connection on my gateway it gives the error below.

All dataflow refreshes are failing!

I was a bit uncertain about the benefit of dataflows for us as we are only on Pro license now I have encountered this problem I will stop using them entirely and go back to the original way of setting these up.

I can imagine Dataflows for Premium users are useful but for Pro users they are pointless. And currently inoperable for us.



Regular Visitor

I'm getting the same error but when refreshing a report that uses data from a dataflow (together with some other data).


  • On-premises data gateway is updated to the latest version
  • Dataflow is refreshing fine
  • All datasources are accessible
  • Refresh on Power BI desktop is working fine
  • Re-entered the credentials on the dataflow


Anyone an idea? Issue popped up today out of nowhere.

New Member

I have exacttly the same issue as @KristofDMi has. It satrted yesterday.


Any input would be appreciated.




Regular Visitor

Same issue here, just like @KristofDMi refered. Also started yesterday. 


All datasets that uses dataflow data gives error on refresh related to authentication token.

"Access token has expired, resubmit with a new access token"


If we try to create a new Dataflow connection we get the error @gooranga1 refered.

"The service returned an invalid token."


Power Participant

@dribeiroIt looks like this functionality has now changed. It look slike you can no longer set up a DataFlow connection on the gateway.

You have to set it up in each dataset of a report as picture pic2.png