Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

DAX function "RELATED" does not work between DirectQuery and Import tables.

When using the DAX function "RELATED" to add a new column from an Imported table to a DirectQuery table, I receive an error. This error does not occur if both tables are using DirectQuery.

Column: SampleColumn = RELATED(ImportTable[Column])

Error: "The column 'ImportTable[Column]' either doesn't exist or doesn't have a relationship to any table available in the current context."

Relationship: DirectQueryTable[SampleKey] (many) has a relationship with ImportTable[SampleKey] (one)

Cardinality = Many to One (*:1)

Cross filter direction = Both

Make this relationship active = Checked


Note: When creating the column using "RELATED" in the DirectQueryTable table, ImportTable shows up as a suggestion.

Status: Accepted
New Member

 Hi, has this bug been fixed?

Not applicable

Hey, same issue here 🙂 

Regular Visitor

3 years now and still no update???

New Member

Dear MS, 

I have same issue like others, please help. 

PowerBi Desktop - Version: 2.116.622.0 64-bit (April 2023)

Regular Visitor

After 4 years **bleep** has not been solved? What is this?

Helper I

it's kind of ridiculous this still doesn't work... not allowing refresh of directquery datsource to another PBI Dataset. it's insane. why even have that option if you can't refresh?

Regular Visitor

June 2023 The problem still exisits. Anyone have a work-around?

Helper I

not an "efficient" way to do things, but you COULD created a calculated table FROM the directquery source, and link that one instead... but yea, not elegant.

New Member

I added a support table (duplicated value) in Datavers, then between two DATAVERSE tables RELATED function works. However, this does not solve the problem, but I can measure the units value in my table.


The disadvantage of this solution is I have to upload prices added to the second table.  


Super User

Four years later and this is still an issue. So is it really a bug or by design?