Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Being prompted for credentials each time I open Power BI desktop version 2.117.894 and later

Running a VM with 2 processors and 32 GB of RAM
Windows Server 2016 standard 64-bit
Version 1607

OS Build 14393.5501

Everytime I open Power BI Desktop I'm being promtped to re-enter my login credentials... This appears to have started on 2.117.894 which was found after some testing.
This is incredibly frustrating and annoying as I need to enter my full e-mail/AD password (multiple times) and also authenticate via Ping ID every time I open Power BI desktop. Previous version did not have this issue and functioned as expected caching the credentials, allowing me to open a new Power BI desktop window without needing to re-authenticate every time.

I have installed previous version of Power BI but am unable to open and .pbix file I edited in a more recent version... the following list is the versions tested to document when the issues started to occur:

2.115.663 - not re-prompted to login each time, user image shows up, pbix files do not load

2.116.622 - not re-promptedto login each time, user image shows up, pbix files do not load

2.116.996 - not re-prompted to login each time, user image shows up, pbix files do not load

2.117.894 and after - re-prompted for login each time, user image does not show up, pbix files load


The "user image" is simply my avatar that is set on office365 for my user account within my company

None of the labels made sense for this issue, but I was required to add one.

Status: Accepted

Update:

 

There has been internal feedback from engineers about this issue and it will be fixed in a future release, no definite ETA at this time.

 

 

Best regards.
Community Support Team_Caitlyn

Comments
ErwanL
New Member

Thank you @GWerling !
I've tried your workaround 4 hours ago ... and no more prompts !

 

lrgleaner
Regular Visitor

Tried the workaround but could not find "Microsfot Power BI Desktop" in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

 

Am I missing something?

GWerling
Advocate I

@lrgleaner Interesting...I double checked the regkey on the device I remote into that was having the issue and the regkey is correct. By any chance did you perhaps log into the wrong device or was Power BI Desktop removed form that device?

lrgleaner
Regular Visitor

@GWerling I actually had to manually create the folder in the registry and then create the key.  I am not sure why it wasn't there - maybe because I've only have Power BI Desktop on this PC for a few months, and the registry entry is a legacy thing?

 

Anyway, it appears to be working better now.  Thanks for the tip!

FarazS
New Member

The option to disbale WAM seems to be discouraged by officially MS - https://learn.microsoft.com/en-us/microsoft-365/troubleshoot/administration/disabling-adal-wam-not-r...


A coworker came across the solution mentioned here to use the " "updated sign in experience" " option after installing the latest August build and enable the checkbox in "Options -> Security -> Sign in experience" 
Here- Solved: Sign-in Bug Fixed !! - Microsoft Fabric Community

Not see anyting yet (limited search) about a "fix" in a newer version or what the "updated sign in experience" is or is doing

Sanju_BI
Frequent Visitor

Has this Promt issue been sorted..?, cause still I'm getting this on my October update.
Help here..!!