Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

refresh failures

Experiencing a metric ton of refresh failures this morning that site intermitent issues. Error message is:
Failure details: The last refresh attempt failed because of an internal service error. This is usually a transient issue. If you try again later and still see this message, contact support.

I understand transient issues but I am now at 18 failures. Is there a larger issue? Nothing on the support page.

Status: New
Not applicable

We experince almost the same thing but our error message is that it had run out of memory.


"Resource Governing: The operation failed because of insufficient memory. If the dataset is hosted on Premium capacity/server, please consider upgrading the capacity to one with more memory or reducing the memory footprint of your operation. Additional information: Requested 10768269KB, Command Memory Limit 10768269KB, Database Size Before Command Execution 15446131KB."


We have incremental refresh and it works to process the partitions manually through XMLA.

It worked perfectly yesterday late evening and we have tried to remove all the new data that has been added since yesterday and processed the partitions manually. And that worked.

But it still returning the same error message when we trigger the refresh from Power BI Service.


Power BI Premium P1 dataset

Support-ticket: 2102250040005341 


Any ideas?



Helper I

I've had a dataflow set up connecting to salesforce with incremental refresh turned on, it has been running with no issues what so ever. Today it failed, dataflow verifies no problem but fails when refreshed.


This is the error:


Error: Data Source Error : DataSource.Error: invalid query locator {[...]}.. RootActivityId = a4f6b0ef-fa79-49d5-9d94-c6219d77e7d7.Param1 = DataSource.Error: invalid query locator {[...]} Request ID: 2a1b84da-548f-79ea-39ac-aa815b51a201.

I turned off the incremental refresh and it refreshed with no problems, turned it back on and it fails again. 

As far as I am aware nothing has changed, it just started failing.

Community Support



You may take a look at Troubleshoot refresh scenarios.

New Member

I'm also seeing the refresh failure "Failure details: The last refresh attempt failed because of an internal service error. This is usually a transient issue. If you try again later and still see this message, contact support."


This is the second day I've gotten the failure.

Regular Visitor

Same case here : 


Yesterday was resource governing error.  , similar error posted by @Anonymous . Turned of gen2 preview as per microsoft support.

and today it is failing due to Failure details: COM error: mscorlib, A task was canceled..

Regular Visitor


Click Get Help - log a ticket, you can't control Priority and it just says we'll get to you in 8 days. LOL
This is terrible support. I don't even need support I just need the Microsoft Products and Services to work the way they are suppose to and it's what we pay for. I DON'T NEED SUPPORT - Microsoft does. what a joke.

New Member

Experiencing outages ALL day.  This has been Power BI for my organzation since roughly 7am this morning




Regular Visitor

Refresh is now working. I'll get a response from my ticket in a few days and they will ask for details and I'll say it works now. Reponse: Great let us know if it happens again and we'll go through this all over again.

Not applicable

Try loading less amount of data. For Example, if you are loading data for 12 months try to load data for only 6 months. It worked for me

Community Champion


I am sorry and don't mean for this to be rude but this isn't microsoft excel. PowerBi was made to handle the large data sets and to provide multiple years of data. I started with PowerBi when it first released and have multiple reports with 7+ years of analysis. If you truly believe you should only load six months of data into PowerBi you might want to up your expectations. Even if reducing the size of the model would cause some of the refresh failures to work, that should never happen. Microsoft should recognize there is an issue and fix it before it gets to that point. 

That being said, more than half of my refresh failures came from my smallest data sets that only contained 5 days of data. Five Days of Data is a 674 KB model. It failed. My Employee parking report is a 140 KB model. It failed.  My large model is 215,937 kb and it worked perfectly the entire time. 

Please note, my refreshes have currently returned to normal with no changes on my end. This was entirely on Microsoft's side and has somewhat resolved until the next time it happens.