Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Power BI slicer doesn't work on Microsoft Edge

Hello everyone!

 

I have a report created in Power BI Desktop. In this report there is a slicer and a filter for this slicer.

The point is that the filter works fine when I open the report in Google Chrome, but doesn't work on Microsoft Edge.

 

Can anyone help me with this?

Status: Investigating

Get Microsoft Edge version information from customer, but need further investigation.

Comments
v-cazheng-msft
Community Support
Status changed to: Needs Info

Hi @Anonymous 

 

According to the official document Supported browsers for Power BI , Power BI supports these browsers on all platforms where they'are available:

  • Microsoft Edge Chromium.
  • Chrome desktop latest version.
  • Safari Mac latest version.
  • Firefox desktop latest version. Firefox may change the fonts used in Power BI.

Power BI doesn't run in any browsers in iOS10 or previous versions.

 

Could you please tell me the version of your Edge by the method in this link Find out which version of Microsoft Edge you have  and could you please describe the Slicer issue with more details? 

 

Best Regards,

Community Support Team _Caiyun Zheng

Anonymous
Not applicable

Thanks for the reply @v-cazheng-msft 

This is my Microsoft Edge version: Version 94.0.992.50 (Official build) (64-bit)

f_to28_0-1634889438654.png

 

v-cazheng-msft
Community Support

@Anonymous 

 

Thanks for your feedback. The version of my Microsoft Edge is as same as yours. Is it convenient for you to post a download link of the sample pbix file with this issue so we can do test based on it to see whether it is caused by browser or something else?

 

Best Regards,

Community Support Team _Caiyun Zheng

v-cazheng-msft
Community Support
Status changed to: Investigating

Get Microsoft Edge version information from customer, but need further investigation.

david_lagarda
Frequent Visitor

I have the same issue, in order to get around it. I have to delete and add the slicer on the service. It's not ideal but is working now