Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Issue Desktop version (store) - Restore saved database error

Hi to all,


Just got the February 2020 version (Microsoft Store app) and got the error Unable to open document - We weren't able to restore the saved database to the model.


Been looking around the community and options go from unninstalling and then reinstalling, did that but still same issue.


Tried to install the February version standalone however the version available online for download is the December version (although says the upload was made in February 18th) everything works normally but it's not comparable.


Also read that for some previous versions were this happened there was a new install version that solved the issue.


Thanks for the attention.

Miguel Felix

Status: New
Power BI Team

We are still investigating this issue. Please use the December release of Desktop as a workaround:


This issue only affects some machines and if you can help us investigating please reach out to me directly at



Power BI Team

@Leonid_Kostin , I think your issue with DQ source is different. Please try as mitigation to open PBIX file by launching Desktop and using File->Open, not by double clicking on it.

Community Support

Hi all, 


You can keep an eye on the status of this issue in Support site: 




Best Regards,
Qiuyun Yu

Not applicable



Having the same problem since Yesterday (CET) morning.


Removing offending letters from filenames, clean install of Feb.2020 version (incl. removing Power BI folder in AppData tree and reboot) did not help


Only reverting to Dec2019 version works


/Karl Erik Jessen

Regular Visitor

I have the same issue since yesterday. None of my models can be opened in Power Bi desktop.

Installing the december version indeed solved the problem !


Helper IV

@AlexGorev Same here funny enough works on one laptop and doesn't work on another, laptops are identical.

Power BI Team

We understand the root cause and working on the fix. We'll be updating February release as soon as we can.

It is due to the Regional Format setting like below in the image. If you switch form 'English (Germany)' to 'English (United States)' the issue should go away.





Super User

Hi @AlexGorev 


You are saying that we cannot have a different regional setting from the country we have?


I'm in Portugal with Regional format English (Europe). I should change the regional settings to Portugal also?

Regular Visitor


I had Regional format English (Europe). I had changed it to English(USA) in windows settings and February version started to work.

Not applicable

Just encountered the same problem here, @MFelix