Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Issue: Connection through Odata Data connection

Hi we are experiencing an issue and not able to resolve it. Please see the following scenario.

 

Data Source: SAP GWD Server through (REST API)

Data Type: is a TXT file with Tab separated format.

 

So we can see that the connection works well as we can request data from the GWD URL through a Chrome Session, and also we can do the same and receive the data with out errors when we create this ODATA connection on the PowerBi Desktop Application.

When we publish this working model to the Premium Server, publishing reports successfully, and we can setup our gate way with a report of successful connection. Once we try to refresh the data, we receive the following error:

 

Something went wrong

There was an error when processing the data in the dataset.

Please try again later or contact support. If you contact support, please provide these details.Hide details
  • Data source error{"error":{"code":"DM_GWPipeline_Gateway_DataSourceAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_DataSourceAccessError","parameters":{},"details":[],"exceptionCulprit":1}}} Table: DTWOPlanning.
  • Cluster URIWABI-NORTH-EUROPE-F-PRIMARY-redirect.analysis.windows.net
  • Activity ID18724f17-fa15-45c6-9a78-d1896c7743c6
  • Request IDc68f2d2b-1bfc-9f7e-fe02-58f10d6a83da
  • Time2020-12-17 21:45:09Z

    We have tried to publish against a different premium instance and receive the same error.

    We have tried to recreate and publish the data again and we receive the same error.

    The Login Credentials have been validated and tested several times with no change to the experience.

     

We are able to track the request for data from PowerBI to GWD and then the request for data back to FFD instances, with a successful write of data back to GWD server and it seems there is where the issue might lay? 

 

We would love to have your help in solving this mystery.

 

Sincerely,

GERDEMI2

 

Status: New
Comments
v-lili6-msft
Community Support

hi  @gerdemi2 

Please upgrade the gateway to the latest version and also troubleshooting it as below document:

https://docs.microsoft.com/en-us/power-bi/connect-data/refresh-troubleshooting-refresh-scenarios

 

 

Regards,

Lin

gerdemi2
New Member

Hi Lin,

This has been completed and it has not made a difference. Any other ideas? we have even complete rebuilt the data (fresh) and tried again, still same error. We even removed all the data but one column.. still same error.

 

Thanks,

Michael