Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Issue: Cannot go to report from Power BI Dashboard tile in published App

We have an issue since last week Thursday September 30 where a user can no longer go to a report from a dashboard. This is happening on almost every tile in all published dashboard. We have tried the following:

- Cleared the cache in Chrome which broke access to Power BI

- Open in Incognito mode in Chrome

- Use Microsoft Edge

- Tried navigating to report directly and it doesn't open

- Tried republishing the App and it doesn't open

This is an urgent request as it is affecting all Power BI users.

Status: Delivered
Regular Visitor

I have an update and I am able to replicate this problem.

1. I go to a report dashboard page where I am unable to go to any reports regardless of what I do.

2. I then open the work space and I am able to open the report from there. Users do not have access to the workspace, only the published App.

3. I then go back to the App and I am able to go to reports.

4. After this I click Ctrl-F5 to clear the cache at which point I cannot go to reports.

5. I can repeat all steps above in sequence to replicate the problem.

Does anyone know how to fix this?

Regular Visitor

I have an update where I am able to work around the problem by upgrading classic workspace to a new workspace. I also noted that there is no longer an option to revert to classic when creating the workspace. One reason I haven't upgraded the workspace is because Row Level security was not working on one of my reports previously, so I chose to keep all of my existing ones in Classic mode. It seems this bug is limited to Classic workspaces only. Here is what I did to upgrade my workspace to work around this problem:

1. Open the workspace.

2. Click on ... on the left corner then Edit this workspace.

3. Select advanced at the bottom then Upgrade now.

4. Republish the App after upgrade completes.

5. Go to App on landing page for dashboard.

6. To test I cleared the cached Ctrl + F5.

7. I am able to open reports and also navigate to an open reports directly.


Hopefully this gets logged as a bug on Classic Workspaces as Microsoft still has the following link published:


Community Support



It's a related issue on the support page. You may keep an eye on the Awareness and check it later this month.

Regular Visitor

This also affects the custom navigation. It appears to work for non-developers.


Some of my navigation options are completely unresponsive until I click edit and reload the application.

Frequent Visitor

We have  the same issue, only fix for us is too grand users acces to the report in the workspace and replace the tile link with an external link to the workspace version.

Regular Visitor
Community Support



This seems to be fixed now. You may check it again.

Community Support
Status changed to: Delivered