Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Google Analytics - Connector not working

There seems to be a connector for GA4 data now, unfortunately, although it works in the Power Query, as soon as you click 'Close & Apply' it fails with an error.

 

KNP_0-1687387590523.png

 

Error:

KNP_1-1687387764265.png

 

Need this fixed to access GA data.

 

Status: Delivered

Hi @KNP 

I'm glad it's working again . I will change the status to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
KNP
Super User
Super User

Hi @v-yetao1-msft 

 

It seems to be working in both Desktop and once published to the service.

Thanks for the update.

 

 

v-yetao1-msft
Community Support
Status changed to: Delivered

Hi @KNP 

I'm glad it's working again . I will change the status to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

aglpr
Advocate II

Hello Ailsa,

 

On my tenant, the GA4 still not working with the same error. Is the fix already rolled out to everyone?

 

aglpr_0-1688439242597.pngaglpr_1-1688439258736.png

 

JosCrdn
Advocate II

Hello @v-yetao1-msft,

 

I'm still getting this error when publishing

JosCrdn_0-1688461687854.png

And this one when trying to upload

JosCrdn_1-1688461816927.png

 

JosCrdn
Advocate II

As we didn't get response yet and this was marked as delivered I opened this a new issue https://community.fabric.microsoft.com/t5/Issues/Google-Analytics-V2-connector-GA4-not-working-for-a... please vote it to see if it's solved ASAP.  Tagging v-yetao1-msft and aglpr.

Thanks

 

pankumar
Frequent Visitor

@JosCrdn there is a workaround using dataflow in PBI service. you can create a new dataflow in PBI service using GA4 connector and then you can create a table using google analytics' data. Now you can access this dataflow from PBI desktop.

QueryWhiz
Helper V

Was this resolved? I had to use a workardound using windsor.ai to export my GA4 data to PBI, but I don't know if the connector is still having this issues. At least this other option has worked fine 

KNP
Super User
Super User

@QueryWhiz - yes, this has been working for me since July when they released a fix.