Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Gateway - "Apply" button not enabled after mapping datasources



I'm stuck and can't use the on premise gateway because after mapping all datasources within the dataset to a datasource within the on premise data gateway, the Apply button at the bottom still doesn't enable so I can't apply the mapping and thus can't use the gateway. This is insane.


I have ensured that all sources are mapped, there are no missing ones. Have redone multiple times. There are like 30 sources so what a tedious thing it has been to redo it 5 times with each time the same result not being able to Apply.


This is on Chrome Version 76.0.3809.100 (Official Build) (64-bit). 

Status: New
Community Support

Hi @dieterdecaluwe


Based on my test, after we map all the data sources in the dataset to gateway data sources, the Apply button is available. 




In your scenario, please check if all data sources within the dataset are on-premise data sources. Also please ensure you are running the latest on-premises data gateway version 3000.8.452 (August 2019) as ours. 


Best Regards,
Qiuyun Yu 

Advocate I

Hello Yu,


we are using the August 2019 gateway. The data source is a REST API, served from a Django application hosted in Azure which in turn connects to an Azure Postgres database.


If i publish the first time to a new dataset the mapping "Apply" button works.

The scenario where it doesn't work:


In my gateway data sources i have configured to datasource name "myproject"


1) create offline pbix and connect to a few API endpoints:<endpoint1><endpoint2>


2) publish to the power bi cloud


3) gateway mapping of the 2 endpoints, hit apply


4) go back to pbix and add an extra endpoint:<endpoint3>


5) publish again (using same pbix name so dataset will be overwritten)


6) go to dataset settings and configure the gateway to map the missing endpoint 3 


7) apply button does not enable and so we can't save


Same behaviour internet explorer & chrome.




Community Support

Hi @dieterdecaluwe


After you modify the report in Power BI desktop, please check how many data sources display in Data Source settings, ensure all data sources added in the Manage Gateways section. 


Also a new on-premises data gateway version 3000.9.194 is released recently, please update your gateway to this version then test again. 


Best Regards,
Qiuyun Yu

Frequent Visitor


I also had this problem. After doing all the mappings on the gateway the "Apply" label is still grayed out and disabled.  The workaround which worked for me was to create a blank PBIX file with the same file name and replace the original. Then upload the original and replace the blank pbix. This resets the gateway mapping and gives you a fresh start. Hope this works for you as well. 




Frequent Visitor

Stian's solution worked for me.

Not applicable

@StianHog Your solution worked for me.


Just an observation that if there are multiple connections made to the same source but while connecting the case is not consistent across the queries, it creates multiple entries for a same data source resulting in this issue.

Helper I

@StianHog Your solution worked for me in 2023 🙂

Frequent Visitor

@StianHog It works until March 2023. Thank you a bunchhh