Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Gateway disabled

ello, 

 

I wondr if there is someone facing the same problem as me. 

My  Enterprise Gateway was working smoothly until yesterday.  I don't know how but i cannot choose my EG to refresh my dataset : 

constat.JPG

I created a sample report to test the datasources, in the example below the error (EG disabled) is happening when i use a merge join in my power query : 

Cas PBI.JPG

 

when i deploy the report with this step i have this error "You don't have any gateway installed or configured for the data sources in this dataset. Please install a new personal gateway or configure the data source for an existing data gateway" 

 

but deploying without the merge join, everything works fine => i can select the EG! 

 

I use Two souces in my report : 

SQLSEVER for RLS table 

Excle file for Fichier table 

 

It seems strange to have this issue after a join operation in the model. 

 

Thank you in advance for your help. 

 

Best Regards, 

KSABI

Status: Accepted
Comments
vgdits
Frequent Visitor

Hi Herbert,

 

We will try to do so today.

 

Jiri

Anonymous
Not applicable

I've collected some logs for you.  We have OneDrive for business in our organisation.  What is the best way to share this with you from there?

v-haibl-msft
Employee

@Anonymous

 

You can send the link via private message.

 

Best Regards,
Herbert

anselmojg
Advocate II

Hello,

We did experience the same issue a few days ago. Also confirmed that it happens with datasets generated with queries containing Merge and/or Append steps.

 

Asked Microsoft and were adviced to set up a gateway connection for each individual file used as a data source in the queries. Before that, we had a gateway set up for the "parent" folder in a network drive where the multiple files used as data sources are kept (and organized in a series of subfolders). And that fixed the issue, i.e. the gateway became visible again.

 

This new requirement to set up each file explicitly in the gateway is obviously not ideal. Btw, if you use a query pulling files from a folder, a gateway is needed for that folder, i.e. not needed for each individual file contained in that folder... 

 

As said, our issue is now solved but I have mixed feelings since this looks like an uncecessary complication. Before we were simply accessing all files with one gateway for the "parent" folder... I hope that Microsoft can reconsider this "step back"....

 

Anselmo

Anonymous
Not applicable

I have tried @anselmojg workaround and it does indeed resolve the issue.  As an ongoing "solution" its pretty bad.  Just in 1 dataset i had 19 csv files which will grow.  I'm happy to have something to solve the problem short-term, but I hope this isn't the new normal.

v-haibl-msft
Employee

Hi All,

 

I’ve reported it internally to Power BI Team: CRI 49306659
I’ll post here once I get any update about it.

 

Best Regards,
Herbert

Vicky_Song
Impactful Individual
Status changed to: Accepted
 
vgdits
Frequent Visitor

Good morning,

 

We can confirm as well, that adding each file to gateway as data source actualy bring GW back online. Before that we had only the main folder as source - like others had.

 

As temporary solution this is just fine. But it should be fixed, so all files can be accessed via folder data source.

 

Martin

v-haibl-msft
Employee

@Anonymous

 

Could you please also help collect the fiddler traces and shared with me? Please start the traces before publishing the report to Power BI Service, then go to the "Manage gateways" page to click "Test all connections", at last go the the scheduled refresh page.

 

Fiddler.jpg

 

Best Regards,
Herbert

ksabi
Advocate II

Hello all, 

 

like @anselmojg and @vgdits, the gateway is selectebale after declaring the files individualy. 

 

Hope the problem will be fixed soon.

 

Khaled