Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Grow your Fabric skills and prepare for the DP-600 certification exam by completing the latest Microsoft Fabric challenge.

Filtering rows failure: CosmosDB connector

We have a PowerBI report where we get data from CosmosDB using CosmosDB connector(Beta). These PBI reports were working since 6 months and started failing recently. On further troubleshooting we saw the exception at FilterRows step. Here is the error message:

 

DataSource.Error: Syntax error, invalid token '$'.
Details:
List

 

If we start a new PBI report and connect to the same source and filter rows, it still fails. There is no bad data issue as well. We are confused on why this would happen and looking for any solutions/help.
@powerbiservices 

Status: New
Comments
v-qiuyu-msft
Community Support

Hi @sidkasat

 

Does the issue only happen when you do FilterRows step in Query Editor? 

Please update the Power BI desktop to the latest version then test again. 

 

Best Regards,
Qiuyun Yu 

Anonymous
Not applicable

Hi all,

i'm having the same issue. 

I'm using Cosmos DB Connector (not beta anymore as it seems)  and powerBi Desktop Version: 2.72.5556.801 64-bit

 

As sidkasat was mentioning, I can expand different elements of the entries and all will work well.
As soon as I try to filter the data of an expanded column, I receive exactly the same error 

DataSource.Error: Syntax error, invalid token '$'.
Details:
    [List]

Anyone has an idea why is happening? Some issue with the connector?

Thanks

sidkasat
Employee

@Anonymous Yes I was able to solve this.

What data type column are you filtering on? If it's a string column, make sure you convert your data type on the header to Text and then apply to filler.

This was my case where I was filtering on a column with names but the data type was any. So you'll have to make it Text.

 

Let me know if that works for you!

Anonymous
Not applicable

@sidkasat  Many thanks for the quick reply. 
Confirmed, the issue was with the data type (Any instead of Text)

Now it works as expected 

 

Thanks again