Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Error getting OData from Microsoft Graph: Access to the resource is forbidden



I am getting an error "Access to the resource is forbidden" when trying to access Microsoft Graph in Power BI Desktop report.

Microsoft Graph URL is

I am logging in using Organization Account.

I have Global Admin role in the tenant.


The report was working normally for months, but stopped since yesterday.

I even tried creating new one - same result.

Accessing the same URL from Graph Explorer works fine.


What could actually impact this kind of error?

Status: New
New Member

I have the exact issue. Using  OData.Feed("") succesfully for months in with 8 scheduled refreshes per day. First refresh of  June 1st give an  "Access to the resource is forbidden" error messages.




When I test it on I have no issue.


Any suggestion is welcome.



Community Support

Hi @jevgenijmart@pbi_2e,


I have reported this issue internally: CRI 71609700. Will update here once I get any information. 


Best Regards,
Qiuyun Yu

New Member

@v-qiuyu-msft, thanks. Keep is posted.

Not applicable

I'm awaiting the response here, too.


I've got multiple client reports that are using Graph for their row-level security, and this has production reports in stasis. Thanks for looking into this, @v-qiuyu-msft.

Not applicable

eagerly waiting a solution, same issue for me.. i no longer have access to graph api from powerbi desktop using odata or web connectors.

Regular Visitor

@v-qiuyu-msft, thanks for loooking into this.

While waiting for the solution, do you think we could have some kind of the workaround?

For example, would Web API authentication work?

Regular Visitor

@jevgenijmart thanks for raising the issue. @v-qiuyu-msft thanks for looking into it. I thought I was going mad trying to figure out why this had started to happen in my reports!! Look forward to hearing about a  resolution 🙂

Not applicable

I'm having the same issues.

Possible culprit may be that in the June release of PowerBI upgraded the OData drivers to version 4, but the MS Graph doesn't consistently supoort v4 of OData across allthe services.


Any work-around would be appreciated, I can't restrict updates to the end users' powerbi desktop


Not applicable

@Anonymous, this was an issue before June release popped, and I verified that it's broken on the May release as well. I originally had this issue last Thursday, May 31st. It seems like most people collectively woke up this Monday to finally see that their Graph-based queries were broken.

Regular Visitor

@Anonymous nice idea.

But yeah, I was getting the issue since Thursday, May 31st.

It feels like it has something to do with some changes on Azure/Graph API side