Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

ESRI ArcGIS maps arent saving changes

I am using the free, out-of-the-box ESRI ArcGIS map visual.  I built this visual last year and had no trouble., so this isnt an RTFM situation.


I opened the PBIX and the visual looks like it reset to defaults.  Ok, stuff happens so I reconfigured it. 

Well, after saving and going back to the page with the visual, the defaults appear again. 


So, now, I have to publish the report (other changes were made) with an ESRI map that looks different because I cant preserve my changes.


I'm going to guess I am the only person on the planet seeing this issue, but I'd figure I would reach out take a shot.



Power BI Frustration Level: HIGH




Status: Accepted
Not applicable

Hi Iam still having problems wit Arcgis. Cant save changes. To which update are you refering to?

Currently i have version 2.70.5494.761 from june.

Not applicable

The August 2019 update fixed this bug.

Regular Visitor

@Anonymous   Version: 2.72.5556.701 64-bit (August 2019) took care of the issue for me

Not applicable

Thanks all. problem solved 🙂

Advocate IV

With the May version of Power BI this bug is back. If I set the location type to one country and a boundary map then change tabs all the settings are lost. I have also found that if I set the map to show colours and sizes for shapes the settings don't hold. This bug is currently making this map unusable. I hope this can be fixed soon.

New Member

I am having the same issue as Advocate IV.  Yesterday (5/20), I had all of my maps/sheets confirgued to how I needed them with specific color ramps, symbol ranges, and map styles.  I opened it this morning, edited a bit more, saved, and ever since, my maps keep changing to what appears to be a default setting.  Even when I edit a map and save, same thing happens.  Also happens when I edit a map, select a different tab, go back to the tab with the map I edited, same thing happens.  This bug is truly making the maps unusable at this point.  Hope this bug can be fixed soon.

New Member

I solved it by installing last month's update (April 2020), the problem is horrible, hopefully they will correct it in the next update, hopefully it will work for them.



April 2020 PBI Desktop 64bits:


Others old versions:

Advocate IV

Aparently Esri are aware of this issue and are working on it. Lets hope they have it fixed soon. It makes the visual unusable.


New Member

This is still an issue. Are there any updates on a fix?

Frequent Visitor

I also experience same problem. June 2020 and bug not fixed yet.