Showing results for 
Search instead for 
Did you mean: 

Dynamic text box - Measure that returns text doesn't work



I have an issue while using dynamic content in a text box.


If I use the Q&A interface to add a dynamic value based on a measure returning a number, everything works fine.

If I use the Q&A interface to add a dynamic value based on a measure returning a text, nothing is returned (instead of returning the text e.g. "My text" it simply returns nothing).


There is no problem with the measure, as it works if I use it in a card visual or in a shape.


To add even more to the explanation, when I set my measure to return the value 400, it will return 400 in the text box. As soon as I change to return the text "400" instead of the number 400, then it will yield nothing when used in the text box.


Does anyone have already encountered this bug? Is there a solution?


Thank you in advance for your answer

Best regards,


Status: New
Community Support

Hi @Anonymous ,

Could not reproduce it in my side as far as my test.

When you return text from the measure, try to format like this:



In addition, if you have set filters in the report which is different in Q&A interface, the text box in Q&A would return blank.



Best Regards,
Community Support Team _ Yingjie Li

Not applicable



I have tried CONVERT but it doesn't work.

I am aware of the filters but it is a non factor as I have tried on pages with absolutely no filters (visual,page,report). Also, I do not apply any filters through Q&A.

Best regards,


New Member

Same problem - works well in card but not in a text format. Problem: you cannot format a card perfectly like you would need to... 

New Member

I am having the same issue, and I think I know what the issue is.

Do you have a "Calculation Group" in your model?

In creating items in this group, did you specify a "Format String Exprressions" property vale for 1 or more of your measures?

In doing this, it creates a hidden folder within the table that contains your measure(s) called "Format String Measures". 

I think this, and specifically that this folder contains measures with the same name as the actual measures (so far as Power BI is concerned) is the cause of the problem.

I was able to demonstrate this by creating a simple model that only had a date table.
I created a slicer, and used the "Date" column from my date table as its Field value.

A set the slicer to relative, and chose last 52 weeks.

I then created a measure called [Reporting Period (str)] which concatinated the min(DimCalendar[Date]) to the max(DimCalendar[Date]) with a " - " between.
I used this measure in a text box, and it correctly represented the string for the past 52 weeks.
I then opened tabular editor, and added a new "Calculation Group", I named this "test".

I added a new calculation item called "ChangeFormat" with a Dax expression of "DIVIDE(100,10)", and set its "Format String Expression" property to "0.0%".
I save this back to my desktop model.
My textbox, using the dynamic measure described earlier, no showed only an "eye" icon, indicating the measure was either genrating an error, or returning no value.

Frequent Visitor

Nice finding, same happened to me as soon as I added calculated group to my model. 
Where you able to solve for this?  @JohnOCallaghan