Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Datasets in Admin Monitoring workspace fail

Since the first day of opening up the Admin Monitoring workspace, the datasets included there have been failing. For the first day, the Feature Usage and Adoption has failed and after couple of successfull days, the Purview Hub has now also failed. Both have their scheduled refreshes stopped due to constant failures.

 

Since this workspace is totally out of my control even as Power BI Admin, I can't see anything that I could do to fix this. Can't even delete and get it recreated. Could this be somehow linked to the fact that we use admin accounts which need e.g. the Power BI Admin role to be activated?

Status: Investigating

Hi  @TSami ,

 

I don't really understand the description of the problem, are you able to provide some detailed screenshots to show the problem?
Also how long has this problem been occurring? Were your colleagues able to reproduce the problem?
What is the version information of your Power BI Service?

 

Best regards.
Community Support Team_Caitlyn

Comments
v-xiaoyan-msft
Community Support
Status changed to: Investigating

Hi  @TSami ,

 

I don't really understand the description of the problem, are you able to provide some detailed screenshots to show the problem?
Also how long has this problem been occurring? Were your colleagues able to reproduce the problem?
What is the version information of your Power BI Service?

 

Best regards.
Community Support Team_Caitlyn

Anonymous
Not applicable

This issue is the same is in:  https://community.fabric.microsoft.com/t5/Issues/Admin-monitoring-refresh-failure/idc-p/3263456 

 

Except the other issue has screenshots.

 

Problem has been occuring as of at least 25th of may

TSami
Regular Visitor

As mentioned above, this seems to be exactly the same issue as others have.

Not sure what's unclear with the description here, except not having the screenshot initally. Datasets in "Admin monitoring" workspace fail.

The screenshot to show it:

TSami_0-1685611503055.png

And the error:

Data source error: {"error":{"code":"ModelRefresh_ShortMessage_ProcessingError","pbi.error":{"code":"ModelRefresh_ShortMessage_ProcessingError","parameters":{},"details":[{"code":"Message","detail":{"type":1,"value":"The credentials provided for the AdminInsights source are invalid. (Source at AdminInsights.)"}}],"exceptionCulprit":1}}}
Cluster URI: WABI-NORTH-EUROPE-J-PRIMARY-redirect.analysis.windows.net
Activity ID: 512b28d3-38a4-4ad0-9f7f-e65d64dd647f
Request ID: b72d534c-514c-44aa-b2b1-dbec06f037a5
Time: 2023-05-30 11:43:42Z

davidh_lgx
New Member

I have the same issue within the Admin Monitoring workspace of my tenant:

 

davidh_lgx_0-1685608297570.png

 

It seems the issue is caused by having set a requirement for MFA\2FA which the PowerBi service not working with that level of security.

 

In my case, I found that conditional access policies where affecting the power bi service (classed as a cloud-app which was included within a couple of policies through having 'all cloud apps' enabled).

 

Creating an exception within those rules and specifying the cloud app with an ID of 00000009-0000-0000-c000-000000000000 (which is power BI) and leaving it for 24 hours cured the problem.

 

Your's might not be the exact, or even the same, problem but I found further details by clicking the error icon

davidh_lgx_1-1685612799935.png

and then clicking 'See details' 

davidh_lgx_2-1685612828225.png

 

Looking-up some of the details online might give you some clues.

 

Good luck!

karo
Post Patron

The same problem. 

 

Dataset refresh errors with error message:

 

"Something went wrong

  • Data source error{"error":{"code":"ModelRefresh_ShortMessage_ProcessingError","pbi.error":{"code":"ModelRefresh_ShortMessage_ProcessingError","parameters":{},"details":[{"code":"Message","detail":{"type":1,"value":"The credentials provided for the AdminInsights source are invalid. (Source at AdminInsights.)"}}],"exceptionCulprit":1}}} "
XCT
Frequent Visitor

Same issue here :

 

XCT_0-1686039233218.png

 

bogdanblaga
Microsoft Employee

Thanks for the feedback. Please open a support ticket, as we would need to best capture the specific senarios and we will look to fix this for you. We are currently investigating similar refresh errors.